Lora HAT on Raspberry Pi gateway : No JoinAccept

Hello ,

I’m using Lora Hat single channel as a gateway for some tests .

As you can see , at first , it received an UnconfirmedDataUp from a end_device that i don’t use .
Then when i started trying to connect my end_device , there is no JoinAccept .

What can be the problem ?


Since you provided little information, I have to assume that your gateway doesn’t filter where incoming frames come from. LoRa operates on a broadcast basis, thus whatever a node transmits can be received by any gateway in range - even if the gateway is unrelated to the project.

I’m not sure whether Chirpstack does log messages from unrelated devices. I thought it wouldn’t. So are you really sure that the unconfirmed data up was not from your device?

Since you don’t see a Join Accept, have you checked your logs?

  1. The LNS should send a Join Accept.
  2. The Join Accept is treated as a downlink, so it should go to the Gateway Bridge (GWB) component, before getting sent to your gateway. So if it worked, you should see some movement for modulating a downlink, in the Chirpstack GWB and your LoRa gateway.
  3. After the LoRa gateway has modulated the downlink, it will send an acknowlegement back to the GWB - which will cause Chirpstack to log the downlink. I am assuming you are using the Semtech UDP Packet forwarder here. If you are using a really old version of the UDP Packet forwarder that implements GWMP v1 (before UDP Packet Forwarder v3.0, from roughly 2017), then downlinks will not work properly with Chirpstack.

Note that even if (3) does not work for whatever reason (includes the network not correctly preserving the UDP “session” between your gateway and Chirpstack GWB), the downlink would still get modulated and the node will receive it. It will only cause Chirpstack to not log the downlink and FCntDown will not be updated.