Meaning of warning "Backend interfaces API is disabled"


at the start of Chirpstack I have noted the following warning:

chirpstack::api::backend: Backend interfaces API is disabled

It is not clear to me what it means and how to fix it.
Could someone please explain it?

Thank you,

Please ignore the incorrect, ChatGPT-generated garbage answer (@brocaar can you do something about these in the rules?). See the optional backend_interfaces section here: Configuration - ChirpStack open-source LoRaWAN® Network Server documentation


# Note: this interface is used both for passive-roaming and when
# integrating with Join Servers that implement the async interface.

If you aren’t using either of those functionalities, this warning is normal and not important.

1 Like


thank you for the help.
I see that if I enable it using the documentation example port (8080), it does not work:

2023-05-30T06:23:26.318149Z  INFO chirpstack::api: Setting up API interface bind=
thread 'tokio-runtime-worker' panicked at 'error binding to error creating server listener: Address already in use (os error 98)', /usr/local/cargo/registry/src/
note: run with `RUST_BACKTRACE=1` environment variable to display a backtrace
2023-05-30T06:23:26.318443Z  INFO chirpstack::api::backend: Setting up backend interfaces API bind=
Error: task 8 panicked

So I suppose that I should use a different value? Is there any default valid value?
Maybe the documentation could be improved by setting a working example value?


It looks like the ChirpStack gRPC endpoint runs on :8080 by default. I have not used this backend interface service, but if whatever clients are talking to it are configurable, you should be safe to choose another port and point your clients to it.


ok thank you.
I will probably try to move the web interface since I have checked around and 8080 is the default for grpc. But as you said, it does not matter, since it is configurable for the clients.

Maybe updating the example configuration by moving the web interface could be an improvement to avoid other people to get confused as happened to me.


Sorry about this, there was a typo in the configfile template. The default value should be blank (disabling the backend interfaces API). This fixes the issue:

1 Like

No problem, you are wellcome. Thank you for the fix

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.