Missing timestamp in uplink frame prevent OTAA (even if tmst field is present in JSON packet)

Hi,

I can successfully receive packet in my application server, but the received LoRaWAN frame is missing the timestamp field. And I guess it prevents my device to join by OTAA.
I ensured the JSON packet sent to the gateway bridge over UDP is correct using “sudo tcpdump -AUq port 1700”
JSON from raw incoming UDP (without binary header):

{“txpk”:{“imme”:false,“rfch”:0,“powe”:14,“ant”:0,“brd”:0,“tmst”:3920690840,“freq”:868.1,“modu”:“LORA”,“datr”:“SF12BW125”,“codr”:“4/5”,“ipol”:true,“size”:33,“data”:"*********************************************"}}
The UPLINK frame incoming to the device live panel has no “timestamp” field but has null “time” and “timeSinceGPSEpoch” (Gateway do not have a GPS).
I tried to add fake_rx_time in the gateway bridge config but it only fill the “time” field, not the timestamp one.
I’m using a device profile with LoRaWAN 1.0.3 A EU and OTAA enabled.

The time and timeSinceGPSEpoch are not a requirement for a successful OTAA activation :slight_smile:

1 Like

Thanks @brocaar for your reply. So would you say that the raw incoming UDP packet looks ok? So there should be an issue at another stage? Since the device’s uplink seems to be received correctly, were could there be an issue preventing the join response being generated?

Thanks!