Missing uplink messages

My node transmits uplink packets with 10seconds intervals.
After joining in about 2 minutes, I can see uplinks on time(at every 10s).
But, after this time, I can’t see uplinks on time. Sometimes with 30seconds and sometimes with 2minutes.

If the gateway is not able to forward some messages and blocks them, why this not happening with the messages in the first few minutes?

How to solve this issue?

I use Dragino Gateway as packet forwarder.
I did the same test many times with TTN and I am able to see all uplink messages on time. But this doesn’t with Chirpstack Environment.

I have increased the duty time to 60seconds. But, it is still missing.

Since you are using EU868, it might be because of the duty-cycle limitations. You cannot really increase duty cycle time because it is meant to be a fraction of your time on air (e.g. <1%).It’s meant to fit the RF regulations for Europe, so you should not just change it either. This is a node-side thing, not related to Chirpstack. In fact, you should have seen the same behaviour on TTN, if it is really related to the duty-cycle limitation.

You’re also using DR0. Why not enable ADR, to let the node use the highest-possible datarate and lowest-possible transmission power? Other than also reducing air time (possibly allowing more messages to be sent, more often), you might get better battery life.

Actually, first I enabled ADR, but then to be sure I have changed it to DR0(SF12). I will try it by enabling ADR once again.