Mosquitto tls configuration with docker

Hello friends! I have been experimenting issues with configuring MOSQUITTO TLS
I am currently using chirpstack docker-compose
and my MQTT broker is working fine with the TLS certificates:
My mosquitto.conf is (I have tried with the commented lines also):

The problem is with MQTT INTEGRATION:

I also add the following lines as explained in MQTT TLS CONFIG in chirpstack.toml and tried different ways but no succeed

Thank you in advance, any help will be appreciated!

I bet the issue is only a little thing but I can not find it :frowning:

[SOLVED] I solved this issue by using only chirpstack in ubuntu 22.04 LTS (not docker) and configuring everything according to TLS MQTT CONFIG.
Some tips: verify the ownership of the directories where you store the certs (/etc/mosquitto/certs) (etc/chirpstack/certs) give the ownership to users mosquitto and chirpstack respectedly with sudo chown -R chirpstack: /etc/chirpstack/certs for chirpstack certs folder and chown -R mosquitto: /etc/mosquitto/certs for mosquitto certs folder

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.