MQTT topic for gateway config not updated

I’m trying to apply a gateway profile on one of my gateways but the new config is not forwarded to the MQTT broker.
The loraserver logs says msg=“gateway updated”, but there is no config sent to MQTT. I’ve tried restarting loraserver, lora-app-server and mqtt-broker.

LoRa Server pushes the configuration to the gateway when it receives a message from the gateway on the .../stats topic.

Thanks brocaar.

Now I know what to expect, but it doesn’t work. I’m subscribed to gateway/[id]/# and I can see the stats messages, but no config. I’ve tried unsetting gateway profile on the gateway and resetting it again.

I recall seeing the config message once in my initial testing, but now it’s not sent anymore. I’m running LoRa Server v2.4.1.

Any news on this? I’m still not seeing anything on the config topic.

We have the same problem.
Its our production server with 100+ gateways.

Its our test server based on yours docker images.

We use 2.4.1 version.
In older versions change gateway fre work perfect.
Please solve the problem.

Same problem after update to loraserver to 2.5.0 and app to 2.5.0

On same VM with same config with loraserver version 2.3.1 all works good:

Fixed, see Please report bugs the next time by creating a GitHub issue, the forum is great for discussions but not for keeping track of open bugs.

1 Like