MQTT without client certificate

In Mqtt integration error - #3 by brocaar @brocaar said:

Please note that the MQTT certificates are optional. If you have configured your MQTT broker (e.g. Mosquitto) to validate the client-certificates then these are needed, in any other case you can just connect as you normally would to your MQTT broker.

But how can I do that?

When I try to set up the MQTT connection, instead of the “+” like with the other integrations, I only see “Get certificate”.

(And when I click that I get the “Generate certificate” button that leads to the error message mentioned in the thread above.)

The MQTT integration is configured in chirpstack.toml. See section integration.mqtt:

https://www.chirpstack.io/docs/chirpstack/configuration.html

Oh, so the box in the UI is basically just a reminder that I can have an MQTT integration?

So, I had a look at my chirpstack.toml and there’s already an MQTT integration configured:

[integration]
  enabled=["mqtt"]

  [integration.mqtt]
    server="tcp://$MQTT_BROKER_HOST:1883/"
    json=true

I’m guessing that configures this connection from the architecture diagram?

But that would mean if I changed that to my own server, then ChirpStack will break, wouldn’t it?

The [integration.mqtt] configuration configures the ChirpStack MQTT Integration, this can be a different MQTT broker than the MQTT broker used for the gateway communication. You will find the gateway MQTT configuration in the region_XXXXX.toml files (e.g. region_eu868.toml).

2 Likes