Multitech Conduit Conversion: AEP to mLinux


I am trying to convert my Multitech conduit MTCDT-247A-868-EU (AEP version) to mLinux version.
With the multitech instructions, i have downloaded following three files from the

  1. mlinux-factory-image-mtcdt-20170920174413.rootfs.jffs2
  2. uImage–3.12.27-r14.2-mtcdt-20170920171940.bin
  3. mlinux-factory-image-mtcdt-upgrade.bin

Then i copied them 1 by 1 to the conduit directory “/var/volatile/flash-upgrade/” with the help of cygwin and scp commands.

After doing this, i ran the command touch /var/volatile/do_flash_upgrade
followed by

The conduit did took some time to reboot, however, after rebooting, the conduit is still an aep version and not the mlinux (expected). I am saying this because as i enter the Ip address of conduit in my web browser, i get the dash board screen as it always appear with AEP version of the conduits.

Could any one kindly guide me in this regard? Has any one tried to convert the AEP version to mLinux version ?

Thanks a lot.

1 Like

Please see the Multitech docs:

Copy kernel and rootfs to the newly created directory /var/volatile/flash-upgrade:
mkdir /var/volatile/flash-upgrade
cp <uImage path here> /var/volatile/flash-upgrade/uImage.bin
cp <rootfs path here> /var/volatile/flash-upgrade/rootfs.jffs2

I think you must rename the downloaded files to exactly the above names!

If I’m not mistaken:


You could also use the factory-image, but I would recommend using the base-image as it will give you a clean environment, without any software that might conflict.

You might also find this helpful:


Thanks for your quick response. I did download the files and copied them to the required locations.

The command prompt screen with the instructions is attached.
This time when i entered the IP address of the conduit, it did not provide me any dash board. So does this mean that now i have successfully configured my conduit in to LINUX version ?

I don’t know, I would say login again using SSH to try :slight_smile:

Yes, indeed it was a bit stupid question. However, i logged in to the conduit but for this i had to use the default IP ( and used “root” both for the username and password (In AEP it was admin).
I have installed both “LoRa gateway bridge” and “LoRa Packet Forwarder” on the conduit following the instructions.

The following command gives me an error

roo@mtcdt:~# update-rc.d lora-packet-forwarder defaults
update-rc.d:/etc/init.d/lora-packet-forwarder: file doesnot exist

Please note the -ap1 and -ap2 on the instruction page. This allows you to run two packet-forwarders simultaneously (make sure the antennas are not close together!), e.g. for supporting 16 channels. Personally I use this for one EU and one US mCard so that I can test on two different bands :slight_smile:

root@mtcdt:~# /etc/init.d/lora-packet-forwarder-ap1 start
root@mtcdt:~# /update-rc.d lora-packet-forwarder-ap1 defaults

Yes, i understood it from the documentation. I only have one EU version of LoRa card and it is installed in the second slot as -ap2 worked for me.
To enable it (packet forwarder) to start on boot i used

update-rc.d lora-packet-forwarder-ap2 defaults (gave me no errors)

However, in the post,

post i am referring to the setting up lora-gateway bridge. the command

/etc/init.d/lora-gateway-bridge start (this works fine)
But when i run
update-rc.d lora-packet-forwarder defaults (Error:- update-rc.d:/etc/init.d/lora-packet-forwarder: file doesnot exist)

Will this be a problem ?

Sorry, this is a typo in the documentation. Of course this should be:

admin@mtcdt:~# update-rc.d lora-gateway-bridge defaults

Fixed in the documentation source:

1 Like

Thank you. You are indeed a very supportive guy.
Thank a lot once again

1 Like