[Multitech Conduit] install lora-packet-forwarder-usb


I upgraded the mLinux firmware of our Multitech mconduit to the 4.0.1.
I edit /var/config/lora/global_conf.json and /opt/lora/local_conf.json according to the follow link:


I edit server_address, serv_port_up,serv_port_down.
Then I changed conduit mode to packet forwarder mode as follow:
update-rc.d lora-packet-forwarder defaults 80 30
sudo /etc/init.d/lora-network-server stop
sudo nano /etc/default/lora-network-server => ENABLED=”no”
sudo nano /etc/default/lora-packet-forwarder => ENABLED=”yes”
sudo /etc/init.d/lora-packet-forwarder start

Now, I want to install latest version of lora-packet-forwarder-usb *.ipk acording to the following link:




product-id of our conduit is MTAC-LORA-868.

I install lora-packet-forwarder-usb by following command:
opkg install lora-packet-forwarder-usb_1.4.1-r2.0_arm926ejste.ipk

when I want to start /etc/init.d/lora-packet-forwarder-usb, it says that command not found !! when i checked following path, I understood that /etc/init.d/ path, include lora-packet-forwarder, by it has not lora-packet-forwarder-usb!!

Thanks in advance for your help

Best regards


There steps are not needed and might conflict with the LoRa Server provided packet-forwarder package. This is also the reason why the first step in https://www.loraserver.io/lora-gateway-bridge/install/gateway/multitech/ is to reflash / reset your gateway using the base image.

I re flashed multitech conduit. Now I could install lora-gateway-bridge and lora-packet-forwarder-usb without any error. I understand that lora-packet-forwarder there is not any more. I can not found /opt/lora/local_conf.json , in which path I must create local_conf.json?
I read https://www.loraserver.io/guides/troubleshooting/gateway/ link:

    "gateway_conf": {
        "serv_port_down": 1700,
        "serv_port_up": 1700,
        "server_address": "localhost",

I installed lora-gateway bridge in both multitech conduit and loraserver. I don’t know that “server_address” must be set to “localhost” or IP address of loraserver?

We have /var/config/lora/global_conf.json too, what reforms must be implement on global_conf.json
I run following cammand

sudo tcpdump -AUq -i lo port 1700

I have some tcpdump output. But when I run following command
sudo tcpdump -AUq port 1700
I have not any output in side of multitech conduit and loraserver.
How can I restart lora-packet-forwarder-usb?

Please see https://www.loraserver.io/lora-gateway-bridge/install/gateway/multitech/#mlinux-with-mtac-lora-915-or-mtac-lora-868, the configuration path is mentioned there :slight_smile: