No answer to mac command LinkCheckReq when uplink use LR-FHSS

When I ask my device, configured to use LR-FHSS modulation only, to send a LinkCheckReq, I never receive any LinkCheckAns.

Looking at the gateway/…/event/up topic I can see my uplink, but nothing appears in the gateway/…/command/down and gateway/…/event/ack topics.

Hi achichignoud,
How do you configure the device to use LR-FHSS?
I set the device-profile in ChirpStack Application Server to “LR-FHSS only ADR algorithm”.
However, the gateway and device seems still working using LoRa modulation.
Do I need to set the LR-FHSS on the device or gateway?

Thanks a lot in advance.

Hello datnus,

In fact, I didn’t change the device-profile on chirpstack as.
I just configured my device to use a custom ADR profile where I specified that it should use only DR5 (In US915 frequency plan DR5 = LR-FHSS CR1/3: 1.523 MHz BW).
Then, i also configured the packet forwarder to be able to use LR-FHSS modulation:

        "lr_fhss_conf": {
            "enable": true,
            "rf_chain": 0,
            "center_freq": 904600000,
            "syncword": "2C0F7995",
            "chan_cfg": [ 
                { "freq_hz": 903000000, "ocw": 1523000 }, 
                { "freq_hz": 904600000, "ocw": 1523000 }, 
                { "freq_hz": 906200000, "ocw": 1523000 }, 
                { "freq_hz": 907800000, "ocw": 1523000 }, 
                { "freq_hz": 909400000, "ocw": 1523000 }, 
                { "freq_hz": 911000000, "ocw": 1523000 }, 
                { "freq_hz": 912600000, "ocw": 1523000 },
                { "freq_hz": 914200000, "ocw": 1523000}

Currently the LinkCheckReq works for LoRa modulation only.

The reason is that the uplink SNR is used to populate the margin field of the LinkCheckReq to determine the margin above demodulation floor. Currently (afaik) gateways do not expose the uplink SNR for LR-FHSS modulated uplinks.

If somebody knows if there is a way to use the uplink RSSI of the LR-FHSS modulated uplink then please let me know and I can update the handling of this mac-command :slight_smile: