No gateway connection after ChirpStack Gateway Bridge 4.0.4 upgrade

After I have performed the recent V4 upgrade to ChirpStack Gateway Bridge 4.0.4 there is no gateway connection to the server anymore.

During upgrade there was the question if to keep or modify /etc/chirpstack/region_eu868.toml.
I decided to keep the old file first and then modified the minor changes like name out and id in.

Does anyone had the same issue and solved it or can give me a hint? Would appreciate very much!

True. No auto merge of toml files yet.
I have to backup toml files and manually merge every upgrade.

Hi datnus,
thanks for your reply.

Issue is reproducible: After installing Chirpstack 4.2.0 and the settings of the file /etc/chirpstack/region_eu868.toml, gateway still runs. But as soon as afterwards upgraded to ChirpStack Gateway Bridge 4.0.4, the gateway cannot connect anymore.
(Gateway connected via Semtech UDP Packet Forwarder.)

@all, @brocaar,
Is it just me who has the problem or is there a bug in the version 4.0.4?

Check the toml file for the bridge.
It is usually at /etc/chirpstack-gateway-bridge.

Thanks for the hint, but no difference before and after the upgrade in chirpstack-gateway-bridge.toml.
I have compared the file content with VS Code to make sure I that I have not missed anything. Problem must be somewhere else.

Did you prefix the gateway topics with the region (new in v4), ie:
event_topic_template=“eu868/gateway/{{ .GatewayID }}/event/{{ .EventType }}”

Hi Jerome,
Yes it was in before the upgrade to 4.0.4 and it is still in the chirpstack-gateway-bridge.toml file exactly as above.

I’m affraid you have to review your toml file line by line, starting with MQTT(S) connection (to see if the gateway can connect to the broker)…

I am also upgraded to v4.2 and gateway connection is lost. Compared new and old region_eu868.toml
The lines that old version were removed

# Event topic template.

# Command topic template.
command_topic="eu868/gateway/{{ gateway_id }}/command/{{ command }}"

replaced with

How to solve it ?

It looks like there was a bug in configuration file(s) loading and a new release will be available soon:

I solve my problem with that changing the gateway bridge service

ExecStart=/usr/bin/chirpstack-gateway-bridge -c /etc/chirpstack-gateway-bridge/chirpstack-gateway-bridge.toml

This worked for me! Thanks very much, samtd

Sorry for the trouble, this has been fixed in v4.0.5.