Node-Red Serial Palette Install Issue

I’ve installed Chirpstack OS on a Raspi 3b+ with a RAK2243. All is functioning well!

I’m now trying to install other palettes, the ‘node-red-node-serialport’ in particular, and and running into the error below. Same error when tried via commandline. Does anyone recommend a path forward?

2021-09-30T18:53:30.262Z Install : node-red-node-serialport 0.14.1

2021-09-30T18:53:29.930Z npm install --no-audit --no-update-notifier --no-fund --save --save-prefix=~ --production --engine-strict node-red-node-serialport@0.14.1
2021-09-30T18:53:59.284Z [out]
2021-09-30T18:53:59.284Z [out] > @serialport/bindings@9.2.4 install /home/root/.node-red/node_modules/@serialport/bindings
2021-09-30T18:53:59.284Z [out] > prebuild-install --tag-prefix @serialport/bindings@ || node-gyp rebuild
2021-09-30T18:53:59.284Z [out]
2021-09-30T18:53:59.331Z [err] sh: line 1: prebuild-install: command not found
2021-09-30T18:54:11.124Z [err] gyp
2021-09-30T18:54:11.125Z [err]
2021-09-30T18:54:11.126Z [err] WARN EACCES
2021-09-30T18:54:11.126Z [err] current user (“admin”) does not have permission to access the dev dir “/home/root/.cache/node-gyp/12.21.0”
2021-09-30T18:54:11.127Z [err] gyp
2021-09-30T18:54:11.127Z [err] WARN
2021-09-30T18:54:11.128Z [err] EACCES attempting to reinstall using temporary dev dir “/home/root/.node-red/node_modules/@serialport/bindings/.node-gyp”
2021-09-30T18:54:11.145Z [err] gyp
2021-09-30T18:54:11.145Z [err] WARN
2021-09-30T18:54:11.145Z [err] install got an error, rolling back install
2021-09-30T18:54:11.151Z [err] gyp
2021-09-30T18:54:11.151Z [err] WARN
2021-09-30T18:54:11.152Z [err] install got an error, rolling back install
2021-09-30T18:54:11.154Z [err] gyp
2021-09-30T18:54:11.154Z [err] ERR! configure error
2021-09-30T18:54:11.155Z [err]
2021-09-30T18:54:11.155Z [err] gyp
2021-09-30T18:54:11.155Z [err] ERR!
2021-09-30T18:54:11.155Z [err] stack Error: EACCES: permission denied, stat ‘/home/root/.node-red/node_modules/@serialport/bindings/.node-gyp/12.21.0’
2021-09-30T18:54:11.156Z [err] gyp
2021-09-30T18:54:11.157Z [err] ERR! System Linux 5.10.31-v7
2021-09-30T18:54:11.157Z [err] gyp
2021-09-30T18:54:11.157Z [err] ERR!
2021-09-30T18:54:11.158Z [err] command “/usr/bin/node” “/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js” “rebuild”
2021-09-30T18:54:11.158Z [err] gyp ERR!
2021-09-30T18:54:11.158Z [err] cwd /home/root/.node-red/node_modules/@serialport/bindings
2021-09-30T18:54:11.158Z [err] gyp
2021-09-30T18:54:11.159Z [err] ERR! node -v
2021-09-30T18:54:11.159Z [err] v12.21.0
2021-09-30T18:54:11.159Z [err] gyp
2021-09-30T18:54:11.159Z [err] ERR! node-gyp -v
2021-09-30T18:54:11.160Z [err] v5.1.0
2021-09-30T18:54:11.160Z [err] gyp ERR!
2021-09-30T18:54:11.160Z [err] not ok
2021-09-30T18:54:12.519Z [err] npm
2021-09-30T18:54:12.519Z [err] ERR! code ELIFECYCLE
2021-09-30T18:54:12.519Z [err] npm
2021-09-30T18:54:12.520Z [err] ERR! errno
2021-09-30T18:54:12.520Z [err] 1
2021-09-30T18:54:12.577Z [err] npm
2021-09-30T18:54:12.577Z [err] ERR! @serialport/bindings@9.2.4 install: prebuild-install --tag-prefix @serialport/bindings@ || node-gyp rebuild
2021-09-30T18:54:12.577Z [err] npm ERR! Exit status 1
2021-09-30T18:54:12.578Z [err] npm
2021-09-30T18:54:12.578Z [err] ERR!
2021-09-30T18:54:12.578Z [err] npm
2021-09-30T18:54:12.578Z [err] ERR!
2021-09-30T18:54:12.578Z [err] Failed at the @serialport/bindings@9.2.4 install script.
2021-09-30T18:54:12.578Z [err] npm
2021-09-30T18:54:12.579Z [err] ERR!
2021-09-30T18:54:12.579Z [err] This is probably not a problem with npm. There is likely additional logging output above.
2021-09-30T18:54:12.667Z [err]
2021-09-30T18:54:12.668Z [err] npm ERR! A complete log of this run can be found in:
2021-09-30T18:54:12.668Z [err] npm ERR!
2021-09-30T18:54:12.668Z [err] /home/root/.npm/_logs/2021-09-30T18_54_12_633Z-debug.log
2021-09-30T18:54:12.707Z rc=1

Can you try what worked for this poster?

There seems to be a page dedicated to this error from npm.

There is also nvm, which you can read up on here.