Not connected websocket api

can you help me please, i dont know what is the error… thanks

1 Like

I observing the same issue after chirpstack upgrade to the latest version

Please see the release notes. You have to make sure that you have Redis 5+ installed.

1 Like

Make sure you are using either the IP address (or at least try that if connected via domain name) of the application server or have properly configured your FQDN or reverse proxy… This often happens if your application server is not on a proper SSL configuration…

Yes, after I install the Redis 5+ version. issue is gone. Thank You.


I get the same error with redis V6.2.5 as well as on V3.2
on a Raspberrypi Zero “Raspbian GNU/Linux 9 (stretch)”

I installed redis v5.0.13 but still get the error “Not connected to Websocket API”.
Checking the log from the application-server I see:

level=error msg=“get event-log for device error” error=“redis stream error: ERR unknown command ‘xread’”

I see the same issue reported in Miscommunication with Redis server - #4 by Hiwa so this ticket can be closed.