Port 8080 ufw allowed but not listening?

Hi ChirpStack fam,

Good to meet yall. I have a bit of an issue accessing the Chirpstack Web Interface. I am using a LoRaWAN gateway with inbuilt gateway bridge, and both the Network and Application servers are installed on my Ubuntu 20.04 hosted on a VM (virtualbox). When I execute systemctl status command on both NS and AS, the statuses are active. However, when I key in either localhost:8080 or 0.0.0.0:8080 onto my browser, the Chirpstack web interface failed to load.

I did some research and found that it could be due to the fact that my port 8080 isn’t open.

So I sudo ufw allow 8080 and it’s now marked as active under the sudo ufw status list.

However, when i execute

sudo netstat -tupna

or

sudo netstat -plnt

No port 8080 is listed under it.

Anyone willing to shed some light on this poor newbie soul? :sweat_smile:

Update 1: Not sure if this is a possible issue, but I set my regional parameter in the NS toml file as AS_923. I changed all the frequency bands accordingly too.

Attaching additional info of my App server toml file in case it contains useful info to solve this mystery.

I am also having the same issue. In my case I am using Ubuntu 18.04 hosted on a VM (EC2 instance) in AWS. I tried to key my VM IP:8080, localhost:8080, 0.0.0.0:8080. But nothing worked. Even I checked my machines port either they are listening or not. But all the required ports are active ! But still no access of Chirpstack web interface. I have followed the following link: https://www.youtube.com/watch?v=5CCrpqPZBwY&t=545s

Usually the logs is a good place to start debugging issues. If nothing is listening on port 8080 then are you sure ChirpStack Application Server is actually started? If not, then the logs can shed some light on why it fails to start.

Hi Brocaar,

Thanks for replying. My Chirpstack Application Server shows “Active” when I systemctl status it.

I am not sure how to access the logs. Is the log actually a file in my system that can be opened with notepad or it needs to be viewed from terminal?

Hi @zhtechintl

you need to use for viewing the log output depends on your distribution uses init.d or systemd.

systemd

journalctl -u chirpstack-application-server -f -n 50

init.d

tail -f /var/log/chirpstack-application-server/chirpstack-application-server.log