"Power" field in "txInfo" (downlink)

Hi,
We are having some troubles with ACK and downlink transmissions with out Kerlink Wirnet iBTS gateway.

While trying to find some information about the TX power of the gateway we realized that the gateway/[mac]/tx topic has a “power” field inside “txInfo”. The current value is 20, we were wondering what that means. Is that too low? Can it get higher? Is that ok? Could we eventually change that value?

Thank you.

This value comes from the lorawan/band package and is set to the default TX power for your region (as specified by the LoRaWAN Regional Parameters). See the DefaultTXPower field for each region definition in: https://github.com/brocaar/lorawan/tree/master/band

Thank you for your reply. Is there any documentation on what values the “DefaultTXPower” can take?

See the LoRaWAN Regional Parameters specification: https://www.lora-alliance.org/lorawan-for-developers :slight_smile:

Great! Thank you very much for your time.

@brocaar @leandrolanzieri

Hi,

I set downlink_tx_power=14 and data rate = 5, in loraserver config file ,but still whenever my node is very near to gateway(less than 5 meters,i could get my downlink data to my node).Do we need some more specific configuration in loraserver config file.

But from longer distance more than 15 meters also i could send uplink data properly to my loraserver with the same node and loraserver config.

My node config:

data rate  : 5
sf : 7
region : 868

Hi.
I have seen that the default tx power for my region is 27. This is the same as what can be seen when subscribing to the gateway tx topic. However I am getting this error: gateway/b827ebfffecb2e32/ack {“mac”:“b827ebfffecb2e32”,“token”:5906,“error”:“TX_POWER”}

I have not found much information on this error. What is causing this?
Thanks

This error is sent by the packet-forwarder. https://github.com/Lora-net/packet_forwarder/blob/master/PROTOCOL.TXT#L428

What do I need to do to fix this? I am using an RAK831 with gateway-bridge-os-base installed that is found on the Loraserver.io. I have tried changing the tx_power in loraserver.toml to 27 but I still get the error.
I am trying to send mqtt downlinks to a node. Will this TX_POWER stop downlinks bring transmitted from the gateway?
Thankyou

Sir, I checked the latest LoRaWAN Regional Parameters specification version, and can not find the DefaultTXPower 14 defined in the https://github.com/brocaar/lorawan/blob/f23da2d4a303a41bcb7b4519692b0e7a7a022a4c/band/band_cn470_510.go#L29.

Is this item deleted in the revision of the specification or I didn’t find it?