Private instance without internet access

Hi, I have been trying to install and develop a solution for localized monitoring without internet. I have installed the packet forwarder, lora gateway bridge on rpi3 with ic880a spi and installed loraserver, and lora application server on another raspberry pi 3. Both are connected to same dlink router and I can even ping their ip address of server from gateway and gateway from server. Please help me to setup with the configuration files and what has to be done to make connectivity without internet. Need help on configuring lora-gateway-bridge.toml and packet forwarder local and global configuration files

Loraserver.toml configuration, lora-app-server.toml configuration files.

Thanks in advance


I don’t think anything special is required. Other than to show the map (e.g. for the gateway), LoRa (App) Server does not require an internet connection.

1 Like


Thanks for the reply. But I have installed the semtech packet forwarder in gateway along with gateway bridge and connected the lan to a d link router. I have a linus machine installed with lora server and lora app server on that lan is also connected to the router. I have also configured the ip address of server in the local_conf.json file of gateway. I have made the ip address of my linus machine to be static and pointed that ip address in local_conf.json. but I dont see the packet forwarder starting when I turn on the gateway. Unless and until I connect the internet to router it is not starting. Could you please provide suggestion to invoke on the startup even I tried invoking the startup script , it is not invoking.


You probably need to debug whatever startup mechanism you were trying to use, it could be anything from non-activation to not running as the correct user or in the correct path, to configuration or hardware issues preventing the packet forwarder from running. There should be logs if it tried and failed, often in /var/log/syslog but perhaps elsewhere.

Incidentally something to be aware of in a situation with no external connectivity is that NTP time probably won’t work. That might not be a big deal, but it also makes it very hard to use SSL as certificates may appear to have been created “in the future”. If you’re going to go stand-alone you need to think about how you handle time, and all of its cascading implications some of which may not be immediately obvious… If you have a GPS that could potentially be your time source, but watch out for situations where one part of the system has the real time and another a wildly incorrect default.

I dont have gps for NTP time. I have changed the time zone of raspberry pi to the correct time zone of mine. Even I tried logging thru tail -f /var/log/syslog, the packet forwarder is running but I dont see the live status on loraserver. It is not even receiving packets and I could see only rf packets received : 0 when i log it. This happens when the gateway is not connected to internet. But with internet it is working perfectly.

Kindly provide me a solution.

First, get yourself some RF packets from an actual node configured to transmit a bit more frequently than usual for testing purposes.

Next make sure the lora-gateway-bridge is running

Then use mosquitto to manually subscribe to the wildcard MQTT topic and see what sort of traffic (gateway/ and application/ ) is being generated.