Problem by adding a gateway to chirpstack


To explain my situation, I use chirpstack on a VPS from a while now. But I have to change the host of chirpstack, which is an other VPS. Then I’ve done it, same configuration, same version same gateways. But now, when I try to connect the gateway on chirpstack, data is recieved, at least the data of the devices that I’ve entered in chirpstack, it goes to the device section, in LoRaWAN Frames, but not in device data. But more importantly, the gateway is not considered as “seen” by chirpstack. But if I switch to the previous chirpstack on the previous VPS (which is still up until I fix my problem) it works fine.

I looked on mosquitto, if there was any thing related to my gateway (other than device frames) and yes, but the gateway still not show as connected.

Does someone has any clue on the origin of the problem?



Hello Laakiin,

Which gateway are you using?

I’ve experienced similar problem (with my Dragino LG308), and solved it by putting my IP adress in the “server adress” configuration of my gateway.

Try connecting to your gateway via WiFi, and getting your IP adress (it should be same as your gateway IP, but the last number may change, for example if your gateway has IP then connecting to it via WiFi will give you an IP like: 10.130.1.X where X is a number between 1-255).

Once you have your IP address (which is same as your IP except for last number), add it to your gateway server address.