Redis Error "Not connected to Websocket API"


I always get the same error message through various places on the Web-GUI of the Application Server:

I searched through the forum and the error message seems to be related to Redis.

I’m on Debian 11.6 and Redis 6.0.16. My configuration for redis in /etc/chirpstack-application-server/chirpstack-application-server.toml looks like this:

# Redis settings
# Please note that Redis 2.6.0+ is required.

# Server address or addresses.
# Set multiple addresses when connecting to a cluster.

# Password.
# Set the password when connecting to Redis requires password authentication.

# Database index.
# By default, this can be a number between 0-15.

# Redis Cluster.
# Set this to true when the provided URLs are pointing to a Redis Cluster
# instance.

# Master name.
# Set the master name when the provided URLs are pointing to a Redis Sentinel
# instance.

# Connection pool size.
# Default (when set to 0) is 10 connections per every CPU.

# TLS enabled.
# Note: this will enable TLS, but it will not validate the certificate
# used by the server.

# Key prefix.
# A key prefix can be used to avoid key collisions when multiple regions
# are using the same Redis database and it is not possible to separate
# keys by database index (e.g. when using Redis Cluster, which does not
# support multiple databases).

I configured it the same in the file /etc/chirpstack-network-server/chirpstack-network-server.toml.

Any suggestions how to fix this? Thanks :slight_smile:

This issue can occur if you put a proxy in front of ChirpStack. See also (for v3): NGINX proxy - ChirpStack open-source LoRaWAN<sup>®</sup> Network Server.

1 Like

Thanks. I’m accessing the application server through a SSH Proxy (with the option ProxyJump). I don’t have access to the proxy server, but from your message above I suspect it’s a NGINX Server. Is there a way to fix this without changing the settings of the proxy server?