Redis memory overcommit must be enabled Warning


Has anyone else seen this warning come through on the Redis Logs??? (I couldn’t see anything on here)

and implemented the recommendation?

chirpstack-redis                   | 1:C 21 Jan 2024 23:37:55.851 # WARNING Memory overcommit must be enabled! Without it, a background save or replication may fail under low memory condition. Being disabled, it can also cause failures without low memory condition, see To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.

Seen it, yes. Here’s the background:

You can choose what’s right for your environment.

Thanks Brian,

I’ll look into it a bit more, Cheers for the links :+1:

I’m using Chirpstack in a Docker environment.