[release] ChirpStack Gateway OS v4.2



This is a very exciting release, as this release migrates the ChirpStack Gateway OS from Yocto to OpenWrt. Thanks to LuCI and the UCI configuration system it is now possible to configure the provided ChirpStack components as well things like network configuration through a web-interface instead of a CLI. This release also splits the packages from the ChirpStack Gateway OS configuration such that these can be integrated in other OpenWrt based projects. Main features that this release brings:


There is no need to configure the ChipStack Gateway OS using a terminal. Powered by LuCI), the ChirpStack Gateway OS now provides an easy-to-use web-interface to configure ChirpStack components and system configuration.

Custom packages

Through the web-interface (and cli) it is possible to install additional software using the OpenWrt package repositories. This has been requested several times, but until now would require to compile a custom ChirpStack Gateway OS image which would take several hours to complete.


  • Update ChirpStack to v4.4.3.
  • Update ChirpStack Concentratord to v4.2.3.
  • Update ChirpStack UDP Forwarder to v4.1.2.
  • Update ChirpStack MQTT Forwarder to v4.1.0.
  • Update Node-RED to v3.0.2.

Upgrade notes

Unfortunately it is not possible to migrate from ChirpStack Gateway OS v4.1.1 to ChirpStack Gateway OS v4.2.0. You need to re-flash your SD-Card with the ChirpStack Gateway OS v4.2.0 image.

Did anyone have success to boot the ChirpStack Gateway OS v4.2 (Base Image) on a Raspberry PI 3 Model B ? It don’t show anything on screen during the boot, don’t get IP address (Ethernet). The img.gz isn’t corrupt (gzip -t), I tried to reflash the sdcard for about 3 times but the problem persists.
I reflashed to the 4.1.1 version and it worked, so I think it has a problem with the v4.2 image.

I couldn’t get it to work either. I ended up building the system starting with bare Raspbian (lite) and adding the prerequisites and the Chirpstack repo + the packet forwarder for the WM1302.

It works great, but I was hoping for a recent image that I could boot up and use in short order.

I tryed a new version ot balenaEtcher in oder to flash de sdcard and the firmware successfully booted. Another contribution is to remove the static IP set in “config interface ‘wwan’” from /etc/config/network, because it can conflict with local area network host.

Note that the static IP address is for the access-point mode which is used by default until you configure Wi-Fi. From that point, it will use DHCP to get an IP from the network. See: Getting started - ChirpStack open-source LoRaWAN® Network Server documentation