[release] LoRa App Server 0.19.0

LoRa App Server 0.19.0


  • Global search on organizations, applications, devices and gateways.
  • Display live device events (the same data as publised over MQTT).
    See also Event logging.


  • When creating an application, show a warning when no service-profile exists.
  • When creating a gateway, show a warning when no network-server has been associated.
  • When creating a device, show a warning when no device-profile exists.


  • Fix organization selector (which would sometimes show an empty value on select).
  • Fix user selector when assigning an user to an organization (which would sometimes show an empty value on select).

Upgrade notes:

Before upgrading, the PostgreSQL pg_trgm extension needs to be enabled.
Assuming the LoRa App Server database is configured as loraserver_as this
extension could be enabled using the commands below.

Start the PostgreSQL prompt as the postgres user:

sudo -u postgres psql

Within the PostgreSQL prompt, enter the following queries:

-- change to the LoRa App Server database
\c loraserver_as

-- enable the extension
create extension pg_trgm;

-- exit the prompt

Hello !

Excuse me to disturb you, I tried yesterday (Wed 4 April) to upgrade my LoRa Server to the last version (on a Debian 9 VM); but, since then, when I look into lora-app-server log, I see this line.

level=fatal msg=“applying migrations error: pq: la classe d’opérateur « gin_trgm_ops » n’existe pas pour la méthode d’accès « gin » handling 0027_global_search.sql”

Here comes a screen capture from a restart of this morning.

Does it come from the new version ? What can I do to solve this problem ?
Thank you very much !

Best regards,

EDIT : Sorry, I have found the solution while looking into the changelogs of the last version, I didn’t change my PostgresQL settings.


I just upgraded the loraserver packages and it resulted in a migration error of the lora-app-server:

level=fatal msg=“applying migrations error: pq: operator class “gin_trgm_ops” does not exist for access method “gin” handling 0027_global_search.sql”

here a little more log:

time=“2018-04-25T15:03:53+02:00” level=info msg=“starting LoRa App Server” docs=“https://docs.loraserver.io/” version=0.20.1
time=“2018-04-25T15:03:53+02:00” level=info msg=“connecting to postgresql”
time=“2018-04-25T15:03:53+02:00” level=info msg=“setup redis connection pool”
time=“2018-04-25T15:03:53+02:00” level=info msg=“handler/mqtt: TLS config is empty”
time=“2018-04-25T15:03:53+02:00” level=info msg=“handler/mqtt: connecting to mqtt broker” server=“ssl://xxx.xxxxx.xxx:8883”
time=“2018-04-25T15:03:53+02:00” level=info msg=“applying database migrations”
time=“2018-04-25T15:03:53+02:00” level=info msg=“handler/mqtt: connected to mqtt broker”
time=“2018-04-25T15:03:53+02:00” level=info msg=“handler/mqtt: subscribing to tx topic” qos=0 topic=application/+/node/+/tx
time=“2018-04-25T15:03:53+02:00” level=fatal msg=“applying migrations error: pq: operator class “gin_trgm_ops” does not exist for access method “gin” handling 0027_global_search.sql”

did anyone had the same issue and has fixed the error already?

Best regards,


Sorry, I already found the answer in this topic: https://forum.loraserver.io/t/release-lora-app-server-0-19-0/1089

After this changes I forced a reinstall:

sudo apt-get install lora-app-server --reinstall

A restart would also have worked :slight_smile:

I am trying to update Lora App Server

I did it exactly what you said but,
On create extension pg_trgm;

It gives me that error

check the requiremetns in the documentation again…

PostgreSQL database

LoRa App Server persists the gateway data into a PostgreSQL database. Note that PostgreSQL 9.5+ is required

so you need to have a newer postgres version, then try again