There is, in my humble opinion, some inconsistency between REST API naming convention in /api/devices and /api/internal/search. The ‘devEUI’ and ‘name’ indexes are named ‘deviceDevEUI’ and ‘deviceName’ in the latter case. Wouldn’t it be better to use the same naming convention for the same items across the API ?
Good catch, I think it would be even better to make an object out of the first device
part, e.g.
{
"device": {
"devEUI": "......"
}
}
Please note, the /api/internal
is not intended to be “exposed”. It is there for the web-interface, but you should not use it to integrate with your application. Hence the prefix “internal”
but I get below error in web too:
{
“error”: “authentication failed: not authorized”,
“code”: 16,
“message”: “authentication failed: not authorized”,
“details”: []
}
but other urls are working fine. just this url get authentication error.