[RN2483] OTAA returning "no_free_ch"

Hi ,

I am in India and I am using RN2483 1.01 Class A device. Thus I have to use a different set of 3 frequencies as specified in the IN_865_867 band in the regional parameter documentation . So I have set these 3 frequencies on channel 3,4,5 on my end node (RN2483 ) using mac set ch freq command along with their duty cycle as 33% each as well as their data rate ranges . At last I have enabled them using mac set ch status command . Also I have disabled the first 3 channels 0,1,2 as they are for European countries and not India .

ABP works flawlessly with NwSKey , AppSkey that matches the values in the ChirpStack Application Server for the node .

For OTAA even after setting the DevEUI , AppEUI and the matching AppKey , when I try to join using mac join otaa : it responds with no_free_ch

I have tried varying the duty cycle of the channels 3,4,5 : 0.1% 1% 10% etc. as I read that this could be an issue related with the duty cycle , but even that did not produce any positive result.

I have also tried factory resetting my device and re-configuring it , but it also failed in making OTAA work .

Then just to try something different I re-enabled the European channels 0,1,2 (868.1 , 868.3 , 868.5 MHz ) and the response was different . Its result was:



I think the “denied” was due to my gateway still being configured for the Indian frequencies .

Otherwise if I reconfigure it to the European freq , I think it will work .

But what I want to do is to make it work for IN_865_867 band of frequencies. But for those it results in no free channels and only gives OK when channels 0,1,2 are also enabled.

So please can you suggest me some solution to this problem? Is this problem specific to my device RN2483 or is it related to the Indian band of frequencies .

Or do I need to update the firmware of my device to resolve this ??

Which software did you use to do this, putty, tera term or the LoRaDevUtility from Microchip?

I utilised the application server , network server and gateway bridge provided by the Chirpstack.io . And utilised the Semtech UDP Packet Forwarder on my gateway Raspi .
The commands were written to the LoRa RN2483 node by connecting to it via putty and then pyserial to deliver these commands to it .

Thank you so much for the Info