Roaming with packet broker: async timeout

Hi @brocaar,
I now got a authorization key for chirpstack from Johan. :grinning:
Unfortunately I get the following error message when a packet with netId 000013 arrives:

time="2021-06-15T19:10:34.923183892+02:00" level=error msg="uplink/data: start passive-roaming error" ctx_id=01dbe56c-ea24-402c-965f-74da7825ab35 dev_addr=260b7f75 error="request error: async timeout" net_id=000013

Assuming it has something to do with the async_time I set it to something different then 0s but with no luck. This is my roaming setup:

[[roaming.servers]]
enabled=true
net_id=“000013”
async=true
async_timeout=“0s”
passive_roaming=true
passive_roaming_lifetime=“0s”
server=“https://eu.packetbroker.io:5138”
authorization=“Key IDXXXX.KEYXXXX”

What might I be able to do?
Marcel

Note that the Packet Broker is using the async api implementation. This means that when ChirpStack makes a request, that the Packet Broker makes an independent request to send back the response. In your case you see a timeout since no response was received.

This is either because the Packet Broker did not make a request to your ChirpStack instance or because the Packet Broker could not reach your ChirpStack instance (configuration or firewall issue).

Thank you for your hints. No luck so far. I tried the following:
I opened and forwarded port 5138 to my internal chirpstack host. Chirsptack is listening on 0.0.0.0:5138 using the bind paramater of the roaming.api section.
netstat -ltepn verifies this
I check using netstat that chirpstack is opening a port to packet broker. And keeps it open.
I also verified using a local nc that the authorization header is part of the post that chirpstack does.
I checked if the forward from the router is working and it is.
Using an iptables rule and the packet counters of iptables I could see that my external requests are being counted but packet broker does not even seem to make a connection request as packet counter does not change.
Is my port number for the forward even correct? And what domain/ip is packet broker using if it is openeing its own connection?
Marcel

@brocaar anything you could help with?

I got contact with Johan from TTN. It seems there are still settings that need to be done on their side. I report back as soon as I have more news.

1 Like