RxInfo altitude

Hi everyone,

Yesterday I updated our chirpstack from version 4.5 to 4.8.1.

I noticed that the value of the “rxInfo[0].location.altitude” property is the same as the value of the longitude.

I was able to verify that the messages on the MQTT server have the correct location values.

Does anyone else have the same situation?

I haven’t yet tried building the system from source and debugging, but looking at line 87 in the below it seems like this could be a simple typo in the backend code.

I’ll raise it as an issue so that it can be looked at, and hopefully corrected in a subsequent release.

2 Likes

Hey,

We upgraded to ChirpStack version 4.8.1 recently and have seen the same issue.

The gateway logs indicate it is sending the correct value so it does seem like a ChirpStack issue.

1 Like

It is definitively a bug, as @matteogales says at the line 87 of the file he shared. Must be “altitude” and not “longitude”. Open a new Issue in the Chirpstack repo, as it’s a bug and needs to be solved.

2 Likes

This was kindly fixed this morning by offizium-berndstorath (Bernd Storath) · GitHub, with his pull request merged into the master branch by Orne.

It was really great to see open source software development working in this really efficient manner.

1 Like