SenseCap T1000 cannot connect

I have a SenseCap T1000-A that I’m trying to get connected but I cannot seem to get past the “JoinAccept” message. I’ve tried turning off the OTAA but then I get no frames at all. Is there any sort of guide for connecting this to the network?

I tried creating a device profile from a generic guide for the T1000 to connect to Helium. Then I tried a pre-configured device profile for another SenseCap device. I tried both with and without the Javascript device codec I found for the T1000 on github. Both get the same results: I see JoinRequest, followed by JoinAccept but no progress past that point, no activation, no data events or frames.

Help!

who’s console are you trying to get this working on?

can confirm they work fine on mine, but i use my own connector to sync with helium.

when setting it up go to Advanced settings -> Lora -> Other Platform

see how you go.

Have you opened port UDP/1700 (Yes, UDP) on ChirpStack machine?

I have opened up a gwmp port to allow incoming roaming through helium yes, but thats not really related to your original question. the Advanced settings -> Lora -> Other Platform is what you need to set it up as in the sensecap config app to join chirpstack.

I’ve done this but I get no frames at all now. There are dozens of parameters on the Chirpstack side and I can guess some but I do not know what they should be. Examples:
MAC version
Regional parameters revision
ADR algorithm
OTAA / ABP
Class-B (and 4 params within it)
Class-C
OTAA Application key
Device address
Network session key (LoRaWAN 1.0)
Application session key (LoRaWAN 1.0)

I’m also using the “Chirpstack” (apparently v4) codec I found here: SenseCAP Decoder | Seeed Studio Wiki

You should choose the TTN codec. It is compatible with ChirpStack v4.

You can use this guide for reference.

MAC version => Should be 1.0.3 or 1.0.4
Regional parameters revision => Try 2-1.0.3
ADR algorithm => Default … (LoRa only)
OTAA / ABP => OTAA
Class-B (and 4 params within it) => No
Class-C => No. Battery node usually use Class A only.
OTAA Application key => To check the AppKey of the node. AppKey is NOT AppSKey
Device address => Will be automatically populated
Network session key (LoRaWAN 1.0) => Will be automatically populated
Application session key (LoRaWAN 1.0) => Will be automatically populated

you just set the t1000 up in the device profile as a normal class a device. or select the one in the current device profile templates if they have it.

you can start by using their one size fits all devices payload codec for starters.

are the device and join eui’s synced with helium packet router?

what console are you using?

There is no profile for the SenseCap T1000 in the profile templates. There are several for other SenseCap devices but I have no idea which one to choose. I tried manually selecting the parameters, then I tried one SenseCap template, then I tried manually adjusting those, now I’m back to a different SenseCap device template.

I have no idea what this is. I have seen several guides and they all point to different codecs but they all seem specific to the device and chirpstack v3 or v4. If there’s a generic one I have not seen it.

I don’t know. I’m simply trying to connect and test one device. I first used TTN but there are few base stations in my area (USA, North Florida) so it barely worked and only outside.

These parameters did not work either, no frames received. The guide you linked is nice and I follow it for the first half, but then it gets specific for OTAA only. It goes on to talk about a “Net key”, “AppSkey” and “NetSkey” which does not appear on my device. I only have Device EUI, AppEUI and AppKey.

For OTAA, you only need DevEUI, AppEUI and AppKey.

1 Like

here is a quick howto i added to helium docs.
who’s chirpstack helium console are you using?

That how-to is not very different from what I did but just to be sure I deleted all my stuff and started over. I followed it but there are many parameters that can be set in the device profile and I don’t know what they should be. In addition you entered a “Join EUI” that I don’t seem to have with my device.

I still get no frames or events.

So to summarize I am set like this:
SenseCAP T1000-A tracker device, set to “Other network”
Using the iot-lorawan console
Region: US915
MAC version: 1.0.4
Regional parameters revision: 2-1.0.3
ADR algorithm: Default … (LoRa only)
OTAA / ABP: OTAA
Class-B: No
Class-C: No
Codec: The TTN codec from here: https://github.com/TheThingsNetwork/lorawan-devices/blob/master/vendor/sensecap/sensecapt1000-tracker-ab-decoder.js
OTAA Application key: [AppKey from my device]
Device EUI: [EUI from my device]
Join EUI: 0000000000000000
Activation Device ID: 78000079 (don’t know where this came from)
Activation Network & Application session keys are filled but don’t know where they came from

Now I get no frames, no connection that I can find

Just make sure your device profile is set as us915 , you should not need to do much here at the moment except create and have the profile for the device to use - you can add in payload decoder stuff later it won’t effect device joining or seeing device or frame events.

The recent specification changes need to be reworded in there documentation… chirpstack shows the correct new standard for devices.

So where the sensecap documentation above shows a value for the app eui enter this value in chirpstack as the join eui ← this is most likely where your problem is especially if you’re entering all zeros for this. Then make sure the app key is also correct.

The activation values come from the LNS. that is a valid helium device address, so at some point it must of tried to join and was heard or you had the keys in the right order.

1 Like