Setting extra_channels in docker-compose-env.yml

Hello

Can anyone help me setting network_server.network_settings.extra_channels in the docker-compose-env.yml file? I can’t figure out the syntax… or if it’s even possible without using the toml (which i’d like to avoid if possible)

in the .toml file these are set by a repeated pattern of:

[[network_server.network_settings.extra_channels]]
frequency=922000000
min_dr=0
max_dr=5

[[network_server.network_settings.extra_channels]]
frequency=922200000
min_dr=0
max_dr=5

[[network_server.network_settings.extra_channels]]
frequency=922400000
min_dr=0
max_dr=5

[[network_server.network_settings.extra_channels]]
frequency=922600000
min_dr=0
max_dr=5

[[network_server.network_settings.extra_channels]]
frequency=922800000
min_dr=0
max_dr=5

[[network_server.network_settings.extra_channels]]
frequency=923000000
min_dr=0
max_dr=5

If I repeat config lines like this in the .yml file docker isn’t happy…

I’ve tried this for AS923, though it doesn’t work

  - NETWORK_SERVER__NETWORK_SETTINGS__EXTRA_CHANNELS__FREQUENCY=["922000000","922200000","922400000","922600000","922800000","923000000"]
  - NETWORK_SERVER__NETWORK_SETTINGS__EXTRA_CHANNELS__MIN_DR=["0","0","0","0","0","0"]
  - NETWORK_SERVER__NETWORK_SETTINGS__EXTRA_CHANNELS__MAX_DR=["5","5","5","5","5","5"]

We do, but unfortunately it’s in a Helm chart, so it’s not a direct copy. Our template has the following:

        {{- if .Values.global.chirpstack.extrachannels.enabled }}
        - name: NETWORK_SERVER__NETWORK_SETTINGS__EXTRA_CHANNELS
          value: {{ .Values.global.chirpstack.extrachannels.channels | toJson | quote }}
        {{- end }}

And the corresponding value files has the following:

    extrachannels:
      enabled: 1
      channels:
        [
          { "frequency": 867100000, "min_dr": 0, "max_dr": 5 },
          { "frequency": 867300000, "min_dr": 0, "max_dr": 5 },
          { "frequency": 867500000, "min_dr": 0, "max_dr": 5 },
          { "frequency": 867700000, "min_dr": 0, "max_dr": 5 },
          { "frequency": 867900000, "min_dr": 0, "max_dr": 5 },
        ]

Sorry it’s not an easy copy-paste.

Figured it out:

  - NETWORK_SERVER__NETWORK_SETTINGS__EXTRA_CHANNELS=[
          {"frequency":922200000,"min_dr":0,"max_dr":5},
          {"frequency":922400000,"min_dr":0,"max_dr":5},
          {"frequency":922600000,"min_dr":0,"max_dr":5},
          {"frequency":922800000,"min_dr":0,"max_dr":5},
          {"frequency":930000000,"min_dr":0,"max_dr":5},
          {"frequency":922000000,"min_dr":0,"max_dr":5}]
2 Likes