Subscription IoTAgent-LoRaWAN with ChirpStack Services

I still trying to make a subscription with ChirpStack the IoTAgent-LoRaWAN and I don’t have a response from this service and I can’t see my data about temperature and relative humidity from my sensors, also I knew that The Things Network is more easy and popular to use, so I connected this network with my IoTAgent-LoraWAN and don’t have problem with it, but I require the same response but from ChirpStack

I read at some post that in the case of my application EUI value default is 0000000000000000

And the other hand, in section provider on Insomnia, I trying with ChirpStack.io and loraserver.io but the problem still

Does someone know how to resolve this problem? Thank you so much :star_struck:

(Also, I add an image from Insomnia)

For anyone else wondering: https://github.com/Atos-Research-and-Innovation/IoTagent-LoRaWAN
Atos was unresponsive and we did not have time to wait for them to react.


The code there should run. We have it deployed on our cluster.
1 Like

I have a SODAQ ExPloRer to send data about temperature and humidity for a college project, at the moment that IoTAgent connects with the MQTT server we can’t visualize this ID we have a connection but can’t see the temperature on the application.
We tried to use the ID DEVICE the name that we register our SODAQ, whit the DeviceEUI and whit the number of the device but doesn´t work.
Does anyone know what my ID Device should be? Thank you!!

Thank you so much @chopmann for all your support we appreciate it!!

And yes we used his image it was possible to communicate with Chirpstack, although the message that the device was not found with that name continues to appear, the data is correctly transmitted to the Orion Context Broker.

At the beginning of using the IoTA there was an error, and looking on the internet we found that it was related to the transported bytes, so I configured my SODAQ device to send few bytes and with this, the problem was solved, after that, change the size again of the frame to send the bytes that it sent in the beginning … so I think it was some kind of bug.

iot-agent_1 | {“timestamp”:“2021-03-26T18:42:05.752Z”, “level”:“info”, “message”:“IOTA provisioned devices:”}

iot-agent_1 | {“timestamp”:“2021-03-26T18:42:05.752Z”, “level”:“info”,“message”: “Decoding CaynneLPP message:B2cA+AhnAOQEaCI=”}

iot-agent_1 | {“timestamp”:“2021-03-26T18:42:05.753Z”, “level”:“error”, “message”:“Could not cast message to NGSI”, “dev_eui”: “0004a30b002212f0”, “dev_id”: “SODAQExpLoRer-1”}


Now it works:

iot-agent_1 | {“timestamp”:“2021-03-26T18:42:36.131Z”, “level”: “info”, “message”: “IOTA provisioned devices:”}

iot-agent_1 | {“timestamp”:“2021-03-26T18:42:36.132Z”, “level”: “info”, “message”: “Decoding CaynneLPP message:AWcA+A==”}

iot-agent_1 | time=2021-03-26T18:42:36.134Z | lvl=DEBUG | corr=n/a | trans=n/a | op=IoTAgentNGSI.NGSIService | srv=infotec | subsrv=/prueba | msg=executeWithDeviceInfo entityName sodaqexplorer-N-001 type LoraDevice apikey attributes [{“name”:“temperature_1”, “type”:“Number”, “value”:24.8}] deviceInformation {“lazy”:[],“active”:[{“object_id”:“rh1”,“name”:“relative_humidity_1”,“type”:“Number”},{“object_id”:“t1”,“name”:“temperature_1”,“type”:“Number”},{“object_id”:“t2”,“name”:“temperature_2”,“type”:“Number”}],“commands”:[],“staticAttributes”:[],“subscriptions”:[],"_id": “605e27a8910a3100076fae6d”, “creationDate”: “2021-03-26T18:27:52.516Z”, “id”:“SODAQExpLoRer-1”,“type”:“LoraDevice”,“name”: “sodaqexplorer-N-001”, “service”: “infotec”, “subservice”: “/prueba”, “internalId”: null, “internalAttributes”: {“lorawan”: {“application_server”:{“host”:“180.179.214.165”, “username”:“user”, “password”:“pwd”,
“provider”: “chirpstack.io”}, “dev_eui”: “0004a30b002212f0”, “app_eui”: “0000000000000000”, “application_id”: “1”, “application_key”: “3ae8feaceaede897d3b38857d60fe244”, “data_model”: “cayennelpp”}}, “transport”:“MQTT”}