Switch to class-c in ABP

I want to use class-c.
I checked the check box as shown.

But now the device is still class-A.
Because after filling in the Payload and port sections, the message is still queued and waiting for the Uplink to occur; it should be sent immediately.
Is it true?

device must operate in class C as its own. simply setting this checkbox does nothing with endnode.

1 Like

I set the End-Device in class-C. but I can’t set class-C in server.

after changes, you need to reactivate device.

1 Like

May you please explain more?

application->device->activation->(re)activate device

1 Like

Thanks a lot.
Queue problem solved. but after downlink, I can’t see any downlink in “Device Data”.
Is it normal?

it depends on gateway packet forwarder which you’re using

1 Like

In class-A it was ok!
I use RisingHF outdoor gateway (SEMTECH UDP Packet forwarder)