Tabs TBHH100 end node not activating

I am using Chirpstack network, application and gateway bridge successfully on a RASPI4 with Dragino PG1302 shield. So far I managed to configure three Dragino end nodes successfully. Unfortunately I have not been able to configure this Tabs end node (temperature/humidity sensor). I believe I got the deveui and appkey right. The live lorawan include UnconfirmedDataUp frames, but I have not seen JoinRequests and JoinAccepts. Under the application/devices the Activation tab page tells me my device has not been activated and does not report device data nor lorawan frames. I have tried different LoaRaWAN 1.0 MAC versions in the device profile and also reversing the APPKey bytes. I am kind of stuck now.
Does anyone have a clue what I could try next?

You might want to hard reset the Tabs by taking out the battery.
You need some thing like a swiss army knife on one of edges to open.
Remove battery and short the terminal for a 30sec as they have a supper cap.

Have LoRaWAN frames on your gateway you should see join request.
I’m new to CS v4 so not too sure you will see join in the Device LoRaWAN frames page.

Replace the battery watch the LEDS on the TABs about 3/50 secs you will see a blue flash then a delay and some more flashes these hopefully will be join requests.

If this isn’t working post back and I will go get some Tabs I have in loft and test with V4.

Thanks so much, iiLaw. It worked! You made my day! I had taken the battery out a couple of times, but never thought of shortening the terminals.
Thanks again!

Good ow …
I’ve had to do this 100s of times
We had a major battery issue with 1000s of Tabs PIRS
It turned out to be the LNS on GW (not chirpstack BTW)

Also same with Elsys sensors if you ever want a hard reboot