Tectelik Kona Enterprise

Hello dear colleagues, I am testing with a Tectelik gateway, but I am not getting adequate responses from the end nodes,

Anyone have experience with these gateways?

The Chirpstack server already sees it but I get fuzzy data


Are you sure the issue is related to the gateway? Did you try the same with a different gateway?

Hello, Thanks! the Winext gateways work well, Tectelik sent us this post: Tektelic - ChirpStack open-source LoRaWAN<sup>®</sup> Network Server, I am starting with this for a client, the difference is the frequency, that’s why I know that some information is coming through the gateway, in the post suggests the installation of an .ipk file, I dont know how to continue, I do not handle that much this system.




As you can see the gateway is connected, I have an end node trying to join, with the freq plan SF10BW125

I’ve tried several configurations, but I still can’t find the correct one.

If you need to see anything else let me know. Thank you

It is not 100% clear what exactly the issue is, but if an other gateway works fine, then it seems to me that your ChirpStack is configured correctly.

In this case it could be that the channel-plan configured on the Tektelic gateway is not properly configured. Depending your configuration, it could be that you are receiving some uplinks, but not all of them. As well it could be that the gateway rejects downlinks because the used downlink frequencies are outside the supported / configured min / max TX frequency.

This is the Gateway configuration:

“board_freq_band”: “US915”,
“chip_enable”: true,
“chan_multiSF_0”: {“chan_rx_freq”: 902300000, “spread_factor”: “7-10” },
“chan_multiSF_1”: {“chan_rx_freq”: 902500000, “spread_factor”: “7-10” },
“chan_multiSF_2”: {“chan_rx_freq”: 902700000, “spread_factor”: “7-10” },
“chan_multiSF_3”: {“chan_rx_freq”: 902900000, “spread_factor”: “7-10” },
“chan_multiSF_4”: {“chan_rx_freq”: 903100000, “spread_factor”: “7-10” },
“chan_multiSF_5”: {“chan_rx_freq”: 903300000, “spread_factor”: “7-10” },
“chan_multiSF_6”: {“chan_rx_freq”: 903500000, “spread_factor”: “7-10” },
“chan_multiSF_7”: {“chan_rx_freq”: 903700000, “spread_factor”: “7-10” },
“chan_LoRa_std” : {“chan_rx_freq”: 903000000, “bandwidth”: 125000, “spread_factor”: 10 },
“chan_FSK” : {“chan_rx_freq”: 903000000, “bandwidth”: 250000, “bit_rate”: 100000 }
“gateway_conf”: {
“server_address”: “”,
“serv_port_up”: 1700,
“serv_port_down”: 1700,

    "//network": "Adjust the following parameters for your network",
    "keepalive_interval": 10,
    "stat_interval": 30,
    "push_timeout_ms": 100,
    "forward_crc_valid": true,
    "forward_crc_error": false,
    "forward_crc_disabled": false,

    "//beacon": "Below are beaconing parameters",
    "//period": "To enable beacon, change the beacon_period to 128",
    "beacon_period": 0,
    "beacon_freq_hz": 923300000,
    "beacon_freq_nb": 8,
    "beacon_freq_step": 600000,
    "//datarate": "From legacy Semtech, this is actually spreading factor",
    "beacon_datarate": 12,
    "beacon_bw_hz": 500000,
    "beacon_power": 30,
    "beacon_infodesc": 0,

    "//time": "To report utc timestamp in packet forwarder, change the following to 1",
    "use_utc_timestamp": 0,

    "//tmms": "To disable the GPS timestamp in packet forwarder, change the following to 0",
    "use_gps_timestamp": 1