Trouble with my OTAA device

Hello, everybody.

I really don’t know very well in which category this post should go.

I just installed my chirpstack server and I have a problem trying to send data with my LoRa device.
First of all, I show you the configuration of my physical device LoRa. This configuration is tested, and it works on The Things Network.

“lora.device-eui”: “{ 0xbd, 0xa0, 0xd4, 0x6d, 0x0e, 0x21, 0x22, 0xdf}”,
“lora.application-eui”: “{ 0x12, 0xab, 0x3c, 0xf1, 0xaa, 0x90, 0x00, 0x07}”,
“lora.application-key”: “{ 0x02, 0x2d, 0x07, 0xa9, 0xaa, 0xaf, 0x60, 0xea, 0x4a, 0xbb, 0xfa, 0xe5, 0x91, 0x3a, 0x7c, 0x3c }”

I create an OTAA device in the chirpstack application. Here I find the first differences. ChirpStack doesn’t have the application-eui parameter, as I read, for chirpstack this parameter can be left at 0.
“lora.application-eui”: “{ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00}”,
Is this correct?

The second difference I find is that chirpstack has a network key parameter, I don’t know what the network key is used for, can anyone help me with this?

Finally, using this configuration for my device:
“lora.device-eui”: “{ 0xbd, 0xa0, 0xd4, 0x6d, 0x0e, 0x21, 0x22, 0xdf}”,
“lora.application-eui”: “{ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00}”,
“lora.application-key”: “{ 0x02, 0x2d, 0x07, 0xa9, 0xaa, 0xaf, 0x60, 0xea, 0x4a, 0xbb, 0xfa, 0xe5, 0x91, 0x3a, 0x7c, 0x3c }”

I get an error with MIC:

in the frames section, we can see that JoinRequest requests arrive, but we don’t get any joinAccept

Can someone help me? Is it necessary to change anything in the configuration of my device? I have tried using the OTAA keys in LSB mode and in MSB mode.

try to revert AppKey LSB/MSB

Hi, you can also check the log file of network server.

You can track all the message and you might find some error over there.

Thank you for your answers.

I tried LSB and MSB and it still doesn’t work. The error I get is: 'Invalid mic

is it possible that i am not using the network key parameter correctly?


Just to confirm:

The only data that you need from the device in order to add it in Chirpstack Application working in OTAA mode are:

  • Device EUI
  • Application Key (AppKey)

You don’t need AppEUI, (at least if you used default .toml config files)

You have to be sure that you enable OTAA mode in the Service Profile.

One more thing:

What do you mean by network key parameter?
Where did you find it?

Good Morning @pulidoj.
thank you for your response

To add an OTAA device I am using device EUI, application EUI and application key. This is what I used in the things network. But I will try to do it without AppEUI as you say.

With the network key parameter I mean this:

I’m not sure how to use it.

once again thank you.

is your device really LoRaWAN 1.1 and not 1.0.x MAC version ?

1 Like

Hi @Sergio,

Yes, @eugenev is right.

I think you are wronk with the device profile you created.
I suggest you to do this:

  • Delete your device.
  • Create 1.0.2 Device Profile.
    So, you will not see Network key (LoraWAN 1.1) and Application key, you will see Application Key and Gen Application Key fields.
  • Add your device using only devEUI and AppKey

Like this, the part in Application Server will be all right, if it doesn’t work, it would be a problem anywhere else.

  • Regards.
1 Like

or change it in current device profile which you’re using with this endnode.

1 Like

Yes, you’re very right.

Thank you @pulidoj, thank you @eugenev, and forgive my delay in answering.

The problem was that i had the device profile set to lorawan 1.1.

I went to the device profile menu and changed the option lorawan mac version to 1.0.2, and my problem was solved.

thanks for your help. I hope this thread can help more people.