Unable to locate package chipstack-gateway-bridge [Key EXPIRED]

While installing chirpstack-gateway-bridge component, I’m getting the following error. Could someone please help me here.

pi@raspberrypi:~ $ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 1CE2AFD36DBCCA00
Executing: /tmp/apt-key-gpghome.GxgLpDwYiv/gpg.1.sh --keyserver keyserver.ubuntu.com --recv-keys 1CE2AFD36DBCCA00
gpg: key 1CE2AFD36DBCCA00: “Orne Brocaar info@brocaar.com” not changed
gpg: Total number processed: 1
gpg: unchanged: 1
pi@raspberrypi:~ $ sudo echo “deb https://artifacts.chirpstack.io/packages/3.x/deb stable main” | sudo tee /etc/apt/sources.list.d/chirpstack.list
deb https://artifacts.chirpstack.io/packages/3.x/deb stable main
pi@raspberrypi:~ $ sudo apt-get update
Hit:1 http://archive.raspberrypi.org/debian buster InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian buster InRelease
Hit:3 http://download.opensuse.org/repositories/home:/strycore/Raspbian_10 InRelease
Get:4 https://artifacts.chirpstack.io/packages/3.x/deb stable InRelease [14.0 kB]
Err:4 https://artifacts.chirpstack.io/packages/3.x/deb stable InRelease
The following signatures were invalid: EXPKEYSIG CFF064C9D12ECB34 Orne Brocaar info@brocaar.com
Reading package lists… Done
W: GPG error: https://artifacts.chirpstack.io/packages/3.x/deb stable InRelease: The following signatures were invalid: EXPKEYSIG CFF064C9D12ECB34 Orne Brocaar info@brocaar.com
E: The repository ‘https://artifacts.chirpstack.io/packages/3.x/deb stable InRelease’ is not signed.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
pi@raspberrypi:~ $ sudo apt-get install chipstack-gateway-bridge
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package chipstack-gateway-bridge

You has typo in package name, ‘r’ is missed. chirpstack-gateway-bridge

This has been fixed, the keyserver in GPG Keychain was not set to keyserver.ubuntu.com :man_facepalming:

It might actually be a good idea to host the public-key on https://artifacts.chirpstack.io so people can pull it directly from there instead of using keyserver.ubuntu.com. Some people have had issues with that in the past so this solves two issues.

You should re-run the following command to fetch the update:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 1CE2AFD36DBCCA00

Please let me know if that solves your issue (it did for me).

Thank you very much for the update. Will check it.

It worked!!
Thank you

1 Like

Great, sorry for the inconvenience (also to others who experienced this issue) and thanks for reporting!

I’m having the same issue again, even tried deleting the keys and reloading them. Still get the error

“Err:5 https://artifacts.chirpstack.io/packages/3.x/deb stable Release
Certificate verification failed: The certificate is NOT trusted. The certificate issuer is unknown. Could not handshake: Error in the certificate verification. [IP: 188.166.134.65 443]”

Solved: This was a docker installation: had to run

sudo apt install ca-certificates

Then everything worked.