Unable to locate package gateway bridge

Hi all,

Today I tried to install LoRa gateway bridge on our LoRa gateway (RFI S-Gateway). Unfortunately I got the message that the the lora-gateway-bridge packet could not be located. I followed the tutorial for debian and got stuck at the install step.

In the step before installing I got the following message: “Skipping acquire of configured file ‘main/binary-armel/Packages’ as repository ‘https://artifacts.loraserver.io/packages/3.x/deb stable InRelease’ doesn’t support architecture ‘armel’”

Distributor ID: Debian
Description: Debian GNU/Linux 9.7 (stretch)
Release: 9.7
Codename: stretch

Does anybody know what I could do?

Thanks in advance!

TL;DR See at the end for a possible solution

This is the root of your problem, your system uses the “armel” ABI, intended to support older ARM processor variations which either do not have floating point hardware, or do not use it. Floating point is done in software and function calls pass floating point values in integer registers.

The offered debian package for ARM appears to only be for armhf, intended for platforms that do have hardware floating point, and make use of it, with function calls passing floating point values in FPU registers.

You may have to wait for a specific answer from @broacaar but the (stale) version of the gateway bridge sitting on one of my ARM gateways appears to not be dynamically linked against system libraries. That might mean that it could actually work on your system if you manually downloaded, extracted, and installed it, in the case that it either a) it does not use any floating point instructions or b) your processor actually has floating point support even through the rest of your OS doesn’t make use of that.

Posting the output of uname -a could be useful

Presumably it should be possible to build the gateway bridge from source on your gateway. Another option could be to install it on a server and use the legacy UDP protocol between the gateway and there.


In https://forum.loraserver.io/t/antique-raspberry-pi/2719 presenting a similar issue it was suggested that rather than try to use a .deb package, try the ARMv6 binary from the downloads page:


It looks like in addition to the .tar.gz there’s also an ARMV6 .deb there you could manually install (dpkg -i or similar)

Perhaps that could ultimately be added to the debian apt integration as an offering for armel.


I think this would be the first thing to test: the armv5 or armv6 .deb package.

Thanks for your suggestion(s).

I tried to install the armv5 .deb package and that seems to be working. I was able to add my gateway in the LoRa App Server where ‘Last seen’ is now ‘a few seconds ago’.

If you are still curious: “Linux s-gateway 4.19.0+ #16 Mon Jan 7 09:59:28 CET 2019 armv5tejl GNU/Linux”

Thanks for your help!