Unable to send data to server

You can use mosquitto_sub to get the base 64 encoded data then u can use online decoder to get the exact data what you sent from device

Mosquitto_sub, obviously, will be used in the same pc, where mosquitto is installed,right?

I use this,exact,command?

please find the screenshot for the output of following commands :

journalctl -u lora-app-server -f -n 50
journalctl -u loraserver -f -n 50

Log for lora-app-server

Log for loraserver

in my server machine there is no file under/var/log/lora-app-server/lora-app-server.log
only three folders are available ,not log files

Hi niko,

Run the below command where you have installed the mosquitto
mosquitto_sub -t “application/+/node/+/rx” -v

Use the below command to run lora-server , lora-app-server etc
set -a
source /etc/default/lora-app-server

@sharmila I tried it again, another time and received above result.

In this pc i have installed mosquitto and mosquitto-client, loraserver,lora-appserve,redis and postgresql.

Hi @sharmila @brocaar

I have tried.but still no luck.Please find the screenshot.It says “no such file or directory”.I have already successfully installed lora-app-server,loraserver etc.

When i just manually start server :

Make sure all the services running
For mosquitto, try below command

sudo /etc/init.d/mosquitto start

In another terminal try mosquitto_sub command.

Can you find the lora-app-server and lora-server configuration file anywhere?
There you need to change port number and ipadress and all.

In lora-app-server file u have to edit the following field
url to access web page:

Yes i have config files available under/etc/lora-app-server

Hope you are asking me to change this IP to my server IP.

@sharmila Thanks your answers and your patience in both issues.

It is supposed to be installed with mosquitto-clients, right?

I can’t fin

d this service by the way.

Yes. What ip and port number you have mentioned in bind same thing u have to use for acessing web page.
Are you getting web page??

Same issue i have faced before.
Can you run mosquitto by how i mentioned above.
if u dont find mosquitto in init.d can u copy to that directory and try once

after this recent ip changes i am not getting web page.

Before webpage was coming.

Actually your configuration file looks different
In my lora-app-server file i changed the below field

ip:port to bind the (user facing) http server to (web-interface and REST / gRPC api) (default: “”)


Have you followed every steps in web UI like creation of network-server instance and all

I am afraid that running mosquitto, as you mentioned in above post, i will disconnect packet forwarding, that is currently running.

In init.d i find only mosquitto and NOT mosquitto_subs.

I understood that ti have to use below commands:
sudo /etc/init.d/mosquitto_sub start

You can try below command also
mosquitto -c /etc/ [path to mosquitto.conf file] /mosquitto.conf -d

In this way will mosquitto_subs may run?

Will i interrupt mosquitto broker data forwarding through server?

It may work. Just try once.

mosquitto_sub result will give the data from server