Unable to send data to server

As u suggested i have registered my device and gateway through web UI. But i don’t know how to proceed further. Please give me some idea about how to send data to server. I have gone through your document (Sending and receiving data), but i didn’t understand completely as am new to this topic.
Please help me with this

Now am successfully sending data from packet forwarder to gateway-bridge which is installed in different device. In web UI am able to see raw and encrypted LoRaWAN frames in Raw frame logs field under device. How to proceed and where exactly i can see my data?

When i give mosquitto_sub -v -t “gateway/+/rx” command ,am getting nothing.

Please help me with this.


I am trying to forward my packets to server from gateway.

In my gateway console i am getting this response,if am i not wrong,gateway is successfully forwarding to server.
sudo tcpdump -AUq port 1700

12:38:02.566913 IP > ec2-13-127-166-63.ap-south-1.compute.amazonaws.com.1700: UDP, length 235
12:38:02.784305 IP > ec2-13-127-166-63.ap-south-1.compute.amazonaws.com.1700: UDP, length 12
E..(..@.@......<...?.   ....u......'.....n

But i am not getting raw data in web ui field under device ,can you please advise me on this?


Hi Praveen,

  • Can you please post lora-app-server and lora-server logs, that is the only place where u can get the solution for your problem

  • Make sure you have registered your device properly that means you have given the proper device details in each field (eg: devaddr, deveui etc)

*Since your telling your getting the data in gateway, after registered your device successfully, try to give mosquitto_sub command and check the result
etc: mosquitto_sub -t “application/+/node/+/rx” -v


Thanks for your quick reply.

mosquitto_sub -t “application/+/node/+/rx” -v

after running that command i am getting the following error:
Connection Refused: not authorised.

Please find the attached log file of lora-app-server,loraserver and tcpdump log result from gateway.


loraserver log:

tcpdump : log

Hello @sharmila.

I achieved a connection between lora server and lora-gateway-bridge. Next, i created 3 devices, in the same Application. Each of them connected, but i observed below issues:

  1. Payload error in loraserver logs. Is any way to see my sent data (payload)?
    I have to use “Integration Field”?

  1. I also noticed that “Live Frames Logs”,in Lora-App-Server, is a little bit slower in footprint of frames. This may caused by internet connection or is parameters configuration issue? I still search it.


Hi praveen,
Try to run the lora-server, lora-app-server and lora-gateway-bridge as follow
set -a
source /etc/default/loraserver

set -a
source /etc/default/lora-app-server

source /etc/default/lora-gateway-bridge

and observe the logs.

Hi nikos
Are you getting anything in mosquitto_sub ??
mosquitto_sub -t “application/+/node/+/rx” -v

Are you using web UI in latest version of browser??


Thanks! I will check like this and update you.

And one more clarification,.are you running lora-gateway-bridge as packet forwarder in your gateway?
if so ,can i just run the below command to do the packet forwarder?

I am using risinghf gateway:
Model : RHF2S008
Can you please recommended packet forwarder ,so that i can try that one


No lora-gateway-bridge is not a packet-forwader. It just forward the packet to lora-server. It just notify you whenever u get packet to your packet forwarder


Thanks for the clarity.

So can you please suggest me an recommended packet forwarder?


Semtech packet forwarder

1 Like

Thanks @sharmila.

I will check with this.I think gateway is by default having this packet forwarder.
If i am not wrong we need to edit the local_config.json file which is available under /home/rxhf/ folder.
and restart packet forwarder.


I have tried this command.But I don’t have folder loraserver in this location /etc/default/ and same for the other two also.

My machine is : ubuntu 16.04

You have to install loraserver , lora-app-server etc.
Refer this

@sharmila @brocaar

I have done with semtech packet forwarder.It catches the packet from my node.Please find the screenshot. But it is not coming to web ui.Can you please advise me on this.

By seeing your screenshots it is clear your packet-forwarder is receiving the packets.
Please share lora-app-server and lora-server logs

Hello @sharmila. Everything is ok. I send data to lora (app) server. My questions are:

  1. How is it possible to see data payload via (HTTP) Integrations?

  2. I also noticed below issue, which i mentioned to another post https://forum.loraserver.io/t/loranet-packet-forward-suddenly-stops/896/2, but i didn’t take answer.


Any idea, about or possible reason?
Have you seen that again?


I have not worked with http integration.
you can refer this.
It looks like issue with packet forwarder

Thanks for the immediate answer @sharmila

Do you believe that may be configuration issue or receive any external packet?

Any other way to see payload except http integration? How do you work?