Unconfirmed adr disabled uplink but adr enabled downlink!

Hi friends,
I have seen that the server, downlinked a unconfirmed downlink in response to unconfirmed uplink with adr bit off:

how can I disable downlinks?

Hi @msadeghz,

I’m not sure the reason because it shows adr: true, but without that in mind, the server is sending a downlink message to set the RXTimingSetupReq mac command, to change the timing of the reception slots.

This has nothing to do with ADR, it is just trying to setup another parameter of your device, and that is ok.

1 Like

as you know, many times downlinks are not recommended for public networks, so I want to disable it and just be enable when adr is true in uplink.

I think this is because I didn’t set RX1 delay in device profile.

I will check and feedback

Hi @msadeghz,

Yes, that’s the reason.

It could be ok to disable ADR for public networks, but one thing is disable ADR and another one is to try to close any kind of downlink communication. ADR only closes one part.

Honestly, I think it doesn’t make sense to close absolutely any downlink communication just because it is a public network, because downlinks commands are a great part of LoRaWAN.

If I’m not wrong, the only part where you could close all downlink communications should be on the LoRa Packet Forwarder of the gateway setting it up to make just Uplinks, but not on the device.
It could make sense depending on the project more than depending on the type of network.


you are right, downlink is the great function of LoRaWAN as an IoT WAN. but as you know, frequently downlink for a node is not recommended.
I will check the issue solution tomorrow and let you know.

I have set 3s for RX1 window which is not as default value of lorawan specification!
I have changed it to 1s and reactivate the device. the issue is resolved.