Update codec not updating or saving

If I create a device profile and set the payload decoder to js add my decoder and hit save it saves fine.

if I go back into the device profile to make any changes to the codec it doesn’t save the edits to the db or take you back to the device profiles on hitting the save button.

can someone else confirm this with the latest version?
chirpstack 4.5.0

seems to be for any updates for the device are effected in the webui that i tried.
rest API still allowed updates.

1 Like

Once confirm possible bug, please submit in issue-tracker. https://github.com/chirpstack/chirpstack/issues

If you checked the issues you would see i already have.

I’m asking if anyone else from here has noticed this as well.

FYI, only reason I posted was because (a) your post had a like (heart), indicating agreement/confirmation with issue and (b) you did not explicitly say you did - posts can be edited/amended.

I tested it today and can’t reproduce the issue…

I have same issue, cant submit.

Apologies, reading back my comments it sounds bad :grimacing:

yes i have reported it :+1:

I seem to be able to create a device profile and edit it until it is assigned to a device. I am unable to edit anything to do with the device its name, description or anything.

here is an example of me just trying to change the description of a device profile.

1 Like

I have the same issue, can create a profile edit the decoder. But after saved it does not except any changes anymore. I am running it in docker through the yml file from ChripStack. Now I need to create for every change in the decoder a new profile and move all devices to the new profile.

there was a fix implemented, i dont think it has been released to docker yet though.

Have you managed to solve this problem? I seem to have the same problem. The submit button does not work in any tab or in Device profiles and Devices. I can’t rename the device, add “Tags” and edit the codec in previous configurations. When I add a new device profile or end device I can edit it for a while.

if you do an update it should be right now.

It is sadly not ok…but there is progress. Previously, submitting simply did nothing. Now, no matter what you do (even simply changing the description) you will get error: Validation errors: Please inspect input fields for errors.

error

Previously, submitting simply did nothing. Now, no matter what you do (even simply changing the description) you will get error: Validation errors: Please inspect input fields for errors.

Note that the form contains multiple tabs and during submit all the fields are being validated. Most likely there is a validation error in one of the fields of the other tabs. Therefore the error message suggests to inspect the input fields for errors. You will find the actual validation error under one of the fields in the form.

man this is embarrassing for me…the issue actually turned out to be a bad browser cache…for some reason, which for the life of me i can’t figure out, everything works fine after a refresh…so for example if i create a test profile and then refresh the page and make changes and submit, everything is suddenly ok! reinstalling my browser fixed everything…sorry for being an ass.

I’m finding i have to refresh the browser cache a bit to reflect changes when in the webui. i actually had the update issue yesterday but due to the self allocated metrics not having a name :joy: but i worked it out quickly.

@brocaar I went home very baffled and defeated yesterday, but came back to work to find the same issue again…but this time I cannot be making a mistake…I have an already created device-profile. as you can see in the video, I select it and attempt to only add a description to an already saved dev.prof and i get the error i mentioned above and that can be seen in the video. Please also note, that it is an incognito window and that i have also tested this with a different browser. what on earth is going on here ??
ezgif.com-optimize

It doesn’t always happen, for example, deleting and re-creating the profile, fixes the issue for a while. So for example I can make changes to the codec etc. but at some point some sort of error occurs and it breaks again, with no obvious way to fix it other than deleting and recreating.

click on the measurements, there will be unnamed labels in there you will have to delete.

:astonished: :astonished: that worked ??? but why would this be causing an issue ??

If you have the automatic measurements detection feature turned on, then ChirpStack will create measurements for you automatically once data has been received, but you have to name these.