Updating app and network server with Docker Compose

Hi Guys

I follow the Docker Compose installation and everything is running smoothly.

Currently the docker compose file is installing version 3.0 correct? https://github.com/brocaar/chirpstack-docker/blob/master/docker-compose.yml

Also, how would I update the install to the latest versions?

Finally, what’s a good backup strategy here?

Yes, it is set to use the latest 3.x branch. At any point, you can shut down the services, run docker-compose pull, and bring them back up with the newest versions.

I would recommend using native Postgres (pg_dump) and Redis tooling to take backups from outside the containers. This would allow you to destroy or move the containers easily at any point, followed by a restore.

Edit: This also makes life easy if/when you migrate off of container-based Postgres to AWS RDS or another non-container deployment.

1 Like

Shutdown and pull will not DROP the database tables correct?

Correct. docker-compose down will destroy the containers, but images and volumes (see the docker-compose file for how these are used for persistence) are not touched. You should verify that it works as expected in your environment, and don’t run docker volume prune, for example.

@bconway under app -> integrations, I only see http / thingsboard / influx

I saw there are more integrations in newer versions so I wonder if I am not running latest afterall ?

you are saying that this
image: chirpstack/chirpstack-application-server:3
will grab latest in 3.x branch ?

or i should change it to :latest for that?

3 will grab the latest 3.x release branch. If you change it to latest, you will be getting the development (master) branch, including test releases.

Example: https://hub.docker.com/r/chirpstack/chirpstack-application-server/tags

Edit: Nevermind, I think I was just blind and mixed the Network Server Container and the Application Server Container. I think the Application Server was indeed updated:
chirpstack/chirpstack-application-server 3 8113ef436d98 2 weeks ago 40.6MB
Please ignore my post below.

I just tried to update my Docker Containers but I think it failed. What I did was

  1. Navigate to the cloned git repository where docker-compose.yml etc. are located
  2. execute docker-compose down command
  3. execute docker-compose pull command
  4. execute docker-compose up command

Now the Loraserver is indeed up again and working, but I think it is still the same version. For the Network Server it was already running 3.6 before so I think there is no newer version, but for the Application Server it could have updated from 3.6 to 3.7 I think. I don’t see the Application Server version in the GUI but looking at the Docker Containers / Images, I have
as container and
as image, but the image shows “5 weeks ago” in created column while 3.7 seems to be out only for 2 weeks, right?
I didn’t change any versions in the docker-compose.yml file so it says version 3 at the top and then the images with :3 tag. Is there anything I’m missing to get a successful update? I see from the website that tag 3 was also updated 2 weeks ago together with 3.7 tag so I’d assume I get 3.7 with the 3 tag, isn’t that right? Or does the created at column lie and I got the update and didn’t notice?
Thanks a lot for any help