Using Multitech Conduit for Class-B

Hi @brocaar, All
I really would like your help…
I have a MultiTech Conduit gateway, and it seems by following the instruction of installing the Packet Forwarder in the documentaion it installing the “Basic Packet Forwarder” version, and I’m trying to use class B.

So any idea on how to switch to the “Beacon Packet Forwarder” version? because I think this version is already included in the “lora-packet-forwarder-usb_1.4.1-r2.0_arm926ejste.ipk” package that I installed.

Many thanks

Does your Conduit have a GPS?

Thanks @brocaar for your response,

The gateway I’m using is: MTCDT-LEU1-210A-EU-GB and I’m not totally sure if its have GPS or not?
In case it does not have a GPS, what are my options please?


We have some of that devices. We don’t use them anymore.

I think they don’t have GPS and you cannot use them for class B. But you should ask multitech, maybe they have a GPS card.
Multitech has another model for exteriors that has GPS, we have them too and they work fine, never used them for Class B but it should work.

There is another model from RisingHF that has GPS, it is based on RPI.

They seem to have a newer model (seems a rip off from Multitech)

We have tested the first one (915MHz) and worked pretty fine and it is cheaper than the multitech one.

Thanks @fma for your quick response, I really appreciate it.

As far as I understand, and since my gateway is static, we can set the GPS coordinates manually and we need the time in order to sync the nodes with the gateway, so is it not possible to use the time from the cellular signal or the gateway internal clock for example?

Thanks ,

I’m not entirely sure. But giving the code a quick look I don’t see any reference to GPS and beacons all together. Maybe it is possible. Take into account that gps is needed because the nodes (having GPS too) and the gateway must be time synced.

As for the version needed to run this beacon forwarder I’m not sure about it, multitech should give you a valid version.
This seems to be the latest version:
But I don’t know if it is compatible with beacons.

You can check a beacon config here:

But I cannot help you much with this as we have not tried beacons.

Thanks again @fma,

I have looked into the RisingHF gateway and contacted them but it cost way over my budget,
However, I have a Raspberry Pi with a Dragino LoRa/GPS hat, so do you think it will work? and if so, is there any documentations for the configurations?


A cheap option that I have tested is the RAK831 gateway kit with GPS (make sure you get the MAX-7Q GPS Module, they have two versions and on my first order I received the wrong one while my order was correct):

1 Like

I think brocaar option is the cheapest option (around 130 euros without the pi).

What you suggest seems to be a hat for making raspberry pi an end node, so it could be a Class B LoRa for example. I think they could be configured to be a 1 channel gateway but never tried this so not sure.

Dear @brocaar, @fma
thank you for your recommendations, and sorry for taking so long to get back to you, but i was dealing with other things.
I have ordered the RAK831 gateway (with the MAX-7Q GPS module) and I’ve installed the semtech packet forwarder.
The issue I have now is once I try to start the packet forwarder, I get the following error message:

ERROR: [main] failed to start the concentrator

I read in other topics that I have to do a hardware reset to overcome this issue.
So I used the following to do so:

./ start
Accessing concentrator reset pin through GPIO7...

However, I’m still getting the same error regarding the concentrator.
Any ideas please?

Many thanks


We are trying a RAK gateway this days, it seems to work fine.

Check if Reset pin is tied to GPIO7 or has been moved

Check this out:

And this post in the forum:

Thanks @fma

You are right, the Reset Pin has been moved to GPIO17