V3_v4 migration - Error "pq: value "2555555555" is out of range for type integer"

Hi

Me again having issues in migrating from v3 to v4…
The migration script now stops at the point of migrating device profiles:

2023/12/18 17:29:44 Migrating device-profiles
2023/12/18 17:29:44 Exec device-profile statement errorpq: value “2555555555” is out of range for type integer

The dabase may not be that clean as this server has been running for years now and handled upgrade from previous version already … Any idea about where to start my search for that “2555555555” unwanted value ?

Many thanks

Solved.

I ran :

postgres@Server:/tmp$ pg_dump --data-only --inserts -U postgres loraserver_as | grep 2555555555
INSERT INTO public.device_profile VALUES (‘c35c3471-52dd-4c50-a5de-741eef4caa25’, 1, 2, ‘2021-11-08 15:31:03.538134+01’, ‘2021-11-08 15:31:12.254785+01’, ‘MySensorProfile’, ‘’, ‘’, ‘’, ‘’, 2555555555000000000);

And found that indeed MySensorProfile had strange values set for Max EIRP and Uplink interval.

Correcting them solved that migration issue