Warnings log chirpstack-network-server

Hello everyone, who can tell me, my log level is Warning
I get the error

time=“2020-03-25T13:57:48Z” level=warning msg=“grpc: addrConn.createTransport failed to connect to {[::1]:8001 0 }. Err :connection error: desc = “transport: Error while dialing dial tcp [::1]:8001: connect: cannot assign requested address”. Reconnecting…”
time=“2020-03-25T13:58:18Z” level=warning msg=“grpc: addrConn.createTransport failed to connect to {[::1]:8001 0 }. Err :connection error: desc = “transport: Error while dialing dial tcp [::1]:8001: connect: cannot assign requested address”. Reconnecting…”
time=“2020-03-25T13:58:31Z” level=error msg=“uplink: processing uplink frame error” ctx_id=b933057e-cb99-4bfb-a416-d753dad769a4 error=“get device-session error: object does not exist”

My NS config

[general]
log_level=3
#log_to_syslog=true
[postgresql]
dsn=“postgres://chirpstack_ns:chirpstack_ns@t_data/chirpstack_ns?sslmode=disable”
[redis]
url=“redis://t_data:6379”
[network_server]
net_id=“000000”
[network_server.band]
name=“RU_864_870”
[network_server.api]
bind=“0.0.0.0:8000”
[network_server.gateway.backend.mqtt]
server=“tcp://t_data:1883”
[join_server.default]
server=“http://localhost:8003

My App config

[postgresql]
dsn=“postgres://chirpstack_as:chirpstack_as@t_data/chirpstack_as?sslmode=disable”
[redis]
url=“redis://t_data:6379”
[application_server.integration.mqtt]
server=“tcp://t_data:1883”
[application_server.api]
bind=“0.0.0.0:8001”
public_host=“0.0.0.0:8001”
[application_server.external_api]
bind=“0.0.0.0:8080”
jwt_secret=“Secret”

Lora-server + Bridge + App running in a single container “t_lw”
postgresql and redis work in the second container “t_data”

root@t_lw:/# netstat -pantu | grep 8001
tcp 0 0 127.0.0.1:8001 127.0.0.1:33956 TIME_WAIT -
tcp 0 0 127.0.0.1:36838 127.0.0.1:8001 ESTABLISHED 9/chirpstack-networ
tcp6 0 0 :::8001 :::* LISTEN 57/chirpstack-appli
tcp6 0 0 127.0.0.1:8001 127.0.0.1:36838 ESTABLISHED 57/chirpstack-appli

That is not a valid hostname / address.

1 Like

Hello Orne :grinning: I tried to do public_host=“localhost:8001”
The situation is the same :pleading_face:

Please note that after updating the public_host, you need to re-save your network-server in the web-interface so that the value propagates :slight_smile: (to be sure you could also restart chirpstack-network-server).

Ok thank you, i try restart NS

I tried, but still this message is repeated
Yes, of course, I save the configuration, it is mounted separately via docker volume and then restart, but this message appears all the same, but everything works, messages from devices come and everything seems stable