What is the best way to upgrade from Lora server to ChirpStack

Hello experts,

I am taking over maintenance of existing working solution using Lora network server, application server, gateway bridge. The system was created as a prototype to prove concept two years ago. It is deployed in Google Cloud Platform (GCP).

  • loraserver version 3.0.2 and lora-app-server version 3.1.0. are running on a VM (Compute Engine) in GCP on Ubuntu 18.04.

  • chirpstack-gateway-bridge version 3.4.0 is running in Lorix-one devices.

  • PostgreSQL and Redis are in GCP.

  • Thingsboard is running on the VM in GCP

My task is to upgrade to ChirpStack latest versions and preserve all configurations so the system continues operating smoothly.

What is the best way to do this? Is it possible just to upgrade from loraserver and lora-app-server to the chirpstack-network-server and chirpstack-application-server while preserving all the settings in the *.toml files?

So far I tried to create a new VM with the latest ChirpStack software, then tried to set the same configurationas in the lora server from the old VM in the corresponding *.toml files. The chirpstack-network-server is running but I am having problems to make the chirpstack-application-server to start.

Oct 12 00:59:51 chirpstack-application-server[12289]: time=“2021-10-12T00:59:51.943911295Z” level=info msg=“integration: configuring global integrations”
Oct 12 00:59:51 chirpstack-application-server[12289]: time=“2021-10-12T00:59:51.944367384Z” level=info msg=“integration/mqtt: TLS config is empty”
Oct 12 00:59:51 chirpstack-application-server[12289]: time=“2021-10-12T00:59:51.944396415Z” level=info msg=“integration/mqtt: connecting to mqtt broker” server=“tcp://localhost:1883”
Oct 12 00:59:51 chirpstack-application-server[12289]: time=“2021-10-12T00:59:51.944950009Z” level=fatal msg=“setup integration error: new integration error: credentials from json error: unexpected end of JSON input”
Oct 12 00:59:51 systemd[1]: chirpstack-application-server.service: Main process exited, code=exited, status=1/FAILURE
Oct 12 00:59:51 momas2 systemd[1]: chirpstack-application-server.service: Failed with result ‘exit-code’.

I looked in the forum messages, and found similar problem reported here:

The solution for that case is to create connection keys in Google Cloud for the project.

But I see, no such keys are created/installed in the old VM and it is working fine.

Any suggestions?

Thank you,