Where do I find sent Class-B beacons in logs?

I just want to know whether my gateway send a beacon successfuly

or can you show me a picture show that beacon send successfuly?

best regards!

The Class-B beacon is sent by the gateway (when configured correctly), not by LoRa Server. Therefore you have to check your packet-forwarder logs for sent beacons.

Hi brocaar ,thanks for your answer

you mean loraserver will not show the beacon log even the gateway send the beacon successfuly?

I think I have not receive a beacon successfuly,like blew picture shows

and I use the lora-net:lora_gateway 5.0.1 packet_forwarder4.0.1
anything without change except blew points

1、DEFAULT_BEACON_FREQ_HZ ->471500000 because my board is 470mhz suport
2、I use the lora_pkt_fwd/global_conf.json and add the blew points
“gps_tty_path”: “/dev/ttyAMA0”,
/* GPS reference coordinates /
“ref_latitude”: 0.0,
“ref_longitude”: 0.0,
“ref_altitude”: 0,
Beaconing parameters */
“beacon_period”: 128,
and change the frequency to 470mhz
3、now it can work well in class A mode,and I can get the right time by the DeviceTimeAns command

4、where is wrong?

Any help will be much appreciate !
best regards


I never tried Class B yet, but I found a mention from Brocaar in another topic regarding GPS …

Please note that in order to use Class-B, you need to have a gateway with GNSS / GPS time synchronization.

Plese also check that the configuration should be like this running on ttyS0 in some cases of GWs.

    "gateway_conf": {
        "fake_gps": false,
        "gps": true,
        "gps_tty_path": "/dev/serial0"


thanks for your answer
I can get the time from the gateway,like the picture shows ,so It may be different from that topic

best regards

my json like picture, and my device work in ABP mode

As I mentioned in my previous post, please check your packet-forwarder logs. You should see something like this when it starts:

INFO: GPS serial port path is configured to "/dev/ttyXRUSB2"
INFO: Beaconing period is configured to 128 seconds
INFO: Beaconing signal will be emitted at 869525000 Hz
INFO: Beaconing datarate is set to SF9
INFO: Beaconing modulation bandwidth is set to 125000Hz
INFO: Beaconing TX power is set to 14dBm
INFO: Beaconing information descriptor is set to 0

Then when you have a GPS fix, it will start scheduling beacons. You will see something like this:

INFO: Beacon queued (count_us=241448927, freq_hz=869525000, size=17):
   => 00 00 00 84 2E 48 BF 0B 00 00 00 00 00 00 00 00 00
INFO: Beacon queued (count_us=369448799, freq_hz=869525000, size=17):
   => 00 00 80 84 2E 48 87 D6 00 00 00 00 00 00 00 00 00
INFO: Beacon queued (count_us=497448671, freq_hz=869525000, size=17):
   => 00 00 00 85 2E 48 8F 3C 00 00 00 00 00 00 00 00 00
### [JIT] ###
# SX1301 time (PPS): 151449086
src/jitqueue.c:452:jit_print_queue(): INFO: [jit] queue contains 3 packets:
src/jitqueue.c:453:jit_print_queue(): INFO: [jit] queue contains 3 beacons:
src/jitqueue.c:459:jit_print_queue():  - node[0]: count_us=241448927 - type=3
src/jitqueue.c:459:jit_print_queue():  - node[1]: count_us=369448799 - type=3
src/jitqueue.c:459:jit_print_queue():  - node[2]: count_us=497448671 - type=3

See the .beacon files for config examples: https://github.com/Lora-net/packet_forwarder/tree/master/lora_pkt_fwd/cfg.


Hi brocaar,
It mean the gateway send the beacon successfuly ? like the picture shows

but I have not receive the beacon by my endnode: maybe something wrong with my endnode(I use the code :lora-net branch-class b NucleoL073)

Hi,I just want to know the gateway you use. Because it is difficult to find a gateway that with installing a GPS module in China.

I’m using the Multitech Conduit and Kerlink iBTS with both have onboard GPS.

1 Like

Thank you for helping, I have another question about the frequency band configuration. Is the configuration related with hardware or only related with the global_conf.json. Because I think that every lora gateway is using SX1301 as concentrator, so I wonder if I change parameters on global_conf.json, then I can change the RX/TX parameter.

And I had another question about the GPS on Multitech Conduit. It says that the gateway have a GPS on the board. However I can not see any GPS antenna on gateway. Is the GPS antenna enclosed in the box? Thank you in advance.

Mine has a GPS antenna connector at the back. Please note that there are versions of the Conduit with and without GPS. Like there are versions with / without cellular and wifi.

I have a question on the same topic, Currently I’m using Semtech IOT starterkit which has inbuilt GPS chip, as showed on earlier text I have enabled GPS port in global_conf.json file which results as below,

Note: parsing UBX frame> b5 62 01 20 10 00 58 41 4d 00 00 00 00 00 00 10 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 _ _ERROR: UBX message is corrupted, checksum failed_ _Note: parsing UBX frame> b5 62 01 20 10 00 58 41 4d 00 00 00 00 00 00 10 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 _ _ERROR: UBX message is corrupted, checksum failed

I have tried connecting antenna and GPS simulator I’m seeing the same. FYI… Using v4.0.1 packet forwarder.
Now, I have enabled fake gps e.g. “fake_gps”: true and fake longitude, latitude, altitude in configuration file ( why ?, because from the code what I understood is, if no GPS component we can use fake GPS for testing class B ).

On running LoRaserver on debug level, I found that below ERROR message from the console,

time=“2018-11-20T11:13:40+01:00” level=error msg=“handle mac-command block error: undefined CID 18” cid=“CID(18)” dev_eui=1111111111111113

CID = 18(0x12) i.e Beacon Timing Request from the node.

Any input on this please.

@brocaar, Actually can’t we test Class B with out GPS, let’s say I’ll enable fake gps and give some my own lattitude, longitude, altitude.

Hi @brocaar,

I have a RAK2245 Pi Hat Gateway. Do you possibly know where I would be able to find the packet-forwarder logs or the global_config.json file? Thank you!

In case of the Gateway OS, you find these in /var/log/messages

1 Like

Thank you very much, you saved my day!