Can't find configuration files

Hi! I just purchased a Rasp-PI 4 board, downloaded the image from the repository for ChirpStack OS, dumped it into the SD card, and starte it.
I was able to setup Wifi and access the system thgru web browser.
I have the general panel (LUCI) on port 80, where I can set up System/Network/Status, etc menus…
I also have the ChirpStack Application server on port 8080 where I can start adding tenants, gateways, devices, etc
Is this one the “ChirpStack Network Server”?
Because I wanted to change the default port from 8080 to another one (my router doesn’t let me “NAT” ant port to 8080) and I can’t find any folder under the name /etc/chirpstack-application-server where I can set up a toml file as stated in the documentation to modify the default port.

Any help?
Thanks!

You can try to search nginx proxy for pi.
Then use nginx to forward port 8080 to 80.

Not an expert but in Chirpstack V4 the network/application server have been merged into one,

The configuration files should be under /etc/chirpstack/chirpstack.toml and the code you are looking for should be:

[api]

  # interface:port to bind the API interface to.
  bind="0.0.0.0:8081"

That file path might not be correct as I am using docker and my config is under ~/chirpstack-docker/configuration/chirpstack, but I assume you would just have to remove the “-application-server” from the path you posted, assuming you are using V4.

If not it shouldn’t be too hard to dig around and find the chirpstack.toml yourself.

Thanks, it looks like my setup is a little weird.
In the folder you pointed, there’s no chirpstack.toml file, but there are a bunch of what look like different regioan templates ( region_us915_0.toml, region_au915_2.toml, region_cn470_5.toml, region_us915_1.toml, etc)
I tried with find / -name chirpstack.toml and the only location for this was under /tmp/etc/chirpstack
(why tmp?) is it going to be removed after every bootup?
And this file only contains

[gateway]
allow_unknown_gateways=true

[integration]
enabled = [
“mqtt”,
]

[integration.mqtt]
json=true
server=“tcp://127.0.0.1:1883/”
[network]
net_id=“000000”
enabled_regions=[“eu868”,]

There’s no general bind port, only for MQTT integration.

What am I missing? I didn’t really change much from the default SD full chirpstach OS image… Only basic wireless setup and thats it

Thanks!

This is currently not possible in the ChirpStack Gateway OS. The configuration is generated the moment you start the chirpstack service based on the uci configuration: