Chirpstack V4.2.0 Network Server not accepting UDP packets from MikroTik gateway

Hi Community Forum

There are a lot of similar topics on the forum, however I was unable to get the setup working. Hoping someone can assist.

I’m trying to setup a local LoRaWAN network. I’ve installed the latest full ChirpStack OS image on a Raspberry Pi 4 Model B.

I’m using a MikroTik LtAP LR9 gateway as the LoRaWAN gateway and have both the Raspberry Pi and Gateway on the same network.

I’m able to ping the gateway from the Raspberry Pi and the Raspberry Pi from the gateway. I’m also able to access the ChirpStack web interface and the network server.

I’ve added the gateway in the web interface and pointed the gateway to the Raspberry Pi’s IP, however the gateway doesn’t show up as online in the web interface.

I used tcpdump and can see that the gateway is trying to communicate with the network server, however the packets are being dropped on port 8080 and it shows that the keepalive timed out on the gateway.

I believe that UDP packets are blocked on port 8080. I saw a post on the UDP bridge and started it up, but it made no difference.

What am I missing? How can I allow UDP packets on port 8080?

@brocaar are you able to assist me please?

I think the correct port for Semtech packet forwarder is UDP/1700. Not UDP/8080.

1 Like

Hi datnus

I tried port 1700 as well, it also timed out on the gateway’s keepalive.

Should I not be able to see port 1700 or 8080 open for UDP by using netstat -plnut? If so I’m not seeing those ports open.

Have you open udp/1700 at the Chirpstack network server?
And have you installed chirpstack-gateway-bridge at the server?

1 Like

This is what I’ve tried so far:

In V4.1.1 of the Gateway OS I also tried to explicitly start the chirpstack-udp-forwarder in /etc with the command “/etc/init.d/chirpstack-udp-forwarder start”. Couldn’t see that the UDP forwarder was actually running in /var/log/messages. Inside the chirpstack-udp-forwarder config file it is configured as below. I expected this to allow port UDP/1700 to be opened.

# Server (hostname:port).

Similarly in V4.2.0 of the Gateway OS I tried to explicitly start the chirpstack-udp-bridge with the command “/etc/init.d/chirpstack-udp-bridge start” as per this post Gateway OS forwarding to TTN

So to answer your questions, I understood that the chirpstack-gateway-bridge is part of the full Gateway OS image. So unless it isn’t started automatically on boot and I need to manually start it?

Also, I tried opening the UDP/1700 port on V4.2.0 in the ChirpStack config in the web interface and it didn’t work. Can you please indicate how I need to open the port? I did it similar to this post (Enable port forwarding for the OpenWrt - cFos Software). I couldn’t find a post specifically for the Gateway OS web interface.

I couldn’t get the ChirpStack Gateway OS to work on my Raspberry Pi. The ChirpStack service runs, but I couldn’t get the gateway bridge or UDP packet forwarder to run and port 1700 was never opened for UDP.

The workaround was to go for a clean Raspbian OS image and manually install the gateway bridge and ChirpStack.

Ensure that the region is correctly added to the MQTT topic prefix as “us915_2” if sub-band 2 is used as example for the US915 region. In this way the gateway showed up as online on the web interface and the device was able to join the LoRaWAN network and send an uplink message.