Configuring WiFi no AP

I am using a raspberry pi 3 and and RAK831 and running through the configuration for the the latest OS release “chirpstack-gateway-os-full-raspberrypi3-20210510105535.rootfs.wic”. I created the SD card and after booting connected to the default AP. I then entered the gateway-config and selected the WiFi option to config the new gateway to connect to my existing SSID but after the gateway reboots it never connects to my WiFi router. Am I doing something wrong? Does the WiFi config option configure a new AP for the Chirpstack gateway? Can I manually add the credentials for my network to have this gateway connect to my existing SSID?

That is the idea when you setup the wifi :slight_smile: You enter the name of your network + password to which the Gateway OS must connect…

Thanks for your response.

If that is the what it is supposed to do then why does it not work? The only way I can get it to connect to my network is to use an ethernet cable. WiFi does not work. Do I need to update the OS with the UPDATE file before it will work? I tried the Pi4 and Pi3 versions of the software and neither will configure the WiFi.

Are you trying wifi and ethernet simultaniously? ChirpStack Gateway OS uses connman for managing the network connections and I believe it prioritizes ethernet over wifi. Alternatively, you could use the connmanctl utility to debug the network interface.

This is what I did, with a Pi3 and a Pi4 with the proper associated software file.

  • I created an SD card with the Full OS file
  • put it in the Pi and booted it up
  • connected to the default access point “chirpstack”
  • used Tera Term, my preferred terminal software, and SSH’ed into the gateway with the default IP
  • executed the “sudo gateway-config” command and configured the gateway. First by selecting the “LoRa concentrator shield” and then “Configure WiFi” and in other attempts I selected “Configure WiFi” only and rebooted.

No matter what I did after the reboot there was nothing. It did not connect to my WiFi. I connected an ethernet connection up to my Pi so I could see what was going on and ifconfig indicated that wlan0 had no configuration. I do not know what version of Linux this software is based on so I looked in to wpa_supplicant.conf and there was no information. I tried to manually configure it like I do on the Raspi OS but that also did not work. Bottom line is I cannot configure the wifi with the gateway-config command and do not see how I am the only one having this issue. I will try the connmanctl and see if that can help me.

Thanks for your time.

This could be helpful: ConnMan - ArchWiki

Thanks. I appreciate the help. I was able to used ConnMan to have it connect to my WiFi. I find it odd I am the only one with this issue but at least I have a work around.