Devices after v3 -> v4 migration not able to join

Hi there,
I have a similar problem like described in Join-Request with no Join-Accept but I am not absolutely sure.
I migrated my installation from v3 to v4 still using a gateway with Gateway OS 3.6.0 Base.
My v4 installation is brand new, not an upgrade/migration on the same server, I tweaked the configuration files used for the v3->v4 migration tool to access the old server which went smooth so far.
All data, seems to be there, also old transmission data and all the devices are activated and work.

But then I had to reset one of my Dragino LHT-65 devices, switch it off an on again and then I have the same issue as described in the thread above, the device sends join requests which do not seem to be answered.
I tracked the logs on the chirpstack server and there all I get is that it emits a join event on MQTT but nothing more, no errors or something.

I moved back to my v3 server for the moment. That was possible because I didn’t upgrade my gateway yet. There a re-join works without issues.
So I am not sure if that could be the problem, the old version of the gateway. The gateway bridge in Gateway OS 3.6.0 is said to support v4, I modified the region file of v4 to work without a prefix during the migration and after the migration I changed it to use the prefix again changing the MQTT config on the gateway, so the configuration of v4 is basically stock except the things you have to change like secret key, network id, …

In the other thread they talk about problems with the APPKEY but I checked that, the APPKEY is correct and it works in v3, why shouldn’t it work in v4?

Any help appreciated to finally make the move to v4…


After another try I solved it.
I forgot that there are two definitions for MQQT template, one for events the other for commands and I only changed the template for events.
So uplinks from the devices worked but answer of the server did not and that was why (re)joining didn’t work…