Error with admin login

Hi I’ve just built and got up a docker compose with chirpstack v4, fresh installation, so I tried to log in with the default credentials (admin,admin) but this is what i get in response. If i type “adminn” i get invalid username/password but if i type “admin” i get an error message in the right up corner saying “incomplete response”


Have you cheked postgreSQL, mosquitto and gateway bridge are all active and running??

yes I did, they are all good, I’ve checked as well the row from the chirpstack’s user table database in POSTGRE but everything seems fine. I really can’t figure this out.
There must be something wrong when it checks the database, cause it can confirm an invalid password or email but it can’t verify somehow an existing user like ‘admin’, I didn’t try to insert a wrong password for admin to see what it does though.

@brocaar I’m so sorry to bother you but I think I need your help with this one, almost a week and I can’t figure it out.

Is your ChirpStack behind any firewall?
Can check Chrome console to see if there is any hint.

Hi I’ve actually found, after a long search, a similar topic with the same problem, and it seems that having chirpstack inside docker inside an emulated machine is creating issues, expecially with the avx and avx2 cpu istructions. Thanks for the help anyway

2 Likes

I recall seeing some PRs related to this and a fixed merged into a specific Rust cryptography project that is used by ChirpStack. I believe these fixes have since been incorporated into ChirpStack, are you already running 4.0.2?

1 Like

I think I have the same problem as 2dadsgn. Also running a clean virtualized docker install (esx hypervisor).
I believe this is the forum post that lead to the PR you’ve seen:
https://forum.chirpstack.io/t/login-issue-with-chirpstack-v4/14578/13
I encountered the problem when 4.0.0 was latest, but unfortunately 4.0.2 doesn’t solve it for me.

hi @bconway yes i was using the latest release and though i didn’t investigate further, it seemed the problem was the missing avx or avx2 instructions. I fixed the problem changing the virtual environment .

Hi all, I’ve just completed a fresh install of Chirpstack 4.1.3 on a Ubuntu 22.04 VM (NOT in docker) running on ESX 7 but get this exact issue. All services are running as expected and I’m no stranger to the installation process. Has anyone managed to figure this out? I’m about to upgrade from 3.x so figured it would be wise to spin up a test VM for 4.x first.

It looks like the AVX2 issue was resolved ages ago - does this mean Chirpstack just isn’t supported on ESX?

I don’t know. The AVX2 issue was related to an incorrect check if the AVX2 was supported or not. In case of the original issue, if the error would occur or not was related to the configuration of the VM environment as well. I can’t say why it doesn’t work for you.

Thanks for getting back to me - I’ve tried multiple rebuilds since with various VM configurations and always hit the same problem, however rolling back to Ubuntu Server 20.04 LTS seems to have done the trick. Not sure why this is and of course the original issue remains but for now I’m sorted.

Obviously I’ll be looking to upgrade at some point in the future so If there are any log files or debug I can provide that’ll help diagnose the issue please let me know.

My ChirpStack 4.0 VM (not docker) even works ok with my ESXi 5.0/5.5.
So I guess it will work for ESXi 7.0.