Lora App Server version 0.18.0 web interface refusing connections

Hello again!

I have generated a new image using loraserver-pi-gen, which caused the new versions of the loraserver applications to be installed.

Then, I updated the configuration files using

$ lora-app-server configfile > lora-app-server.toml
$ loraserver configfile > loraserver.toml
$ lora-gateway-bridge configfile > lora-gateway-bridge.toml

respectively while in the following directories


I managed to point the packet_forwarder to localhost sucessfully, and I see PULL_ACKs, which I believe indicate that everything is running.

I can ping my Raspberry Pi, but, when I try to browse to, I get an ERR_CONNECTION_REFUSED.

Strangely, I do not have access (Permission denied) to the dicrectories


so I haven’t tried to place the configuration files there.

What might be blocking my connection?

I tried to see if there were open connections at port 8080 using lsof -i and I checked that there are many (around 30) entries like the following

lora-app- 786 appserver 56u IPv6 22263 0t0 TCP localhost:45662->localhost:postgresql (CLOSE_WAIT)
lora-app- 786 appserver 57u IPv6 24009 0t0 TCP localhost:45666->localhost:postgresql (CLOSE_WAIT)
lora-app- 786 appserver 64u IPv6 24582 0t0 TCP localhost:45450->localhost:postgresql (CLOSE_WAIT)
loraserve 787 loraserver 3u IPv6 24585 0t0 TCP localhost:45452->localhost:postgresql (CLOSE_WAIT)
loraserve 787 loraserver 5u IPv6 22008 0t0 TCP localhost:45456->localhost:postgresql (CLOSE_WAIT)
loraserve 787 loraserver 6u IPv6 24592 0t0 TCP localhost:45460->localhost:postgresql (CLOSE_WAIT)

What do these mean?

Best regards.

Possibly unrelated, I checked that GW_SERVER_JWT_SECRET, which caused me trouble as seen in https://forum.loraserver.io/t/can-not-register-network-server/407/16, did not appear in loraserver.toml. However, loraserver seems to be running fine.

Another possibly unrelated point: I changed the frequency to US_902_928 at loraserver-pi-gen stage3/04-loraserver/files/loraserver file, but it didn’t carry to loraserver.toml, remaining EU_433.

A post was merged into an existing topic: [release] LoRa Gateway Bridge 2.3.0 / LoRa Server 0.24.0 / LoRa App Server 0.18.0